From Evernote to Obsidian

@chriswaterguy - the links between notebooks don’t come across that way.

@ForGe - tags come over perfectly for me with Yarle. I don’t use nested tags. I’m converting from EN 6.25.2. YMMV from v10.

@akos0215 ,

Thanks for the reply and Yarle. I downloaded via Github and tried converting a few of my folders (from EN legacy - v10 is just too horrible). I’m pretty happy with it overall, as far as getting bulk data into Obsidian. The biggest notebook I did was ~1GB. It only took a couple minutes. No links between notebooks is disappointing, but I tag so heavily that I should be able to find what I need.

The thing that’s tougher for me (but again, I do tag heavily, so…) is that alias links don’t come across. I get a ton of files that say “xxxxx.md has not been created yet”. I made a test folder with 4 notes, 1 of which was new, 2 notes that were duplicates of others, 1 an alias of one of the duplicates, then created a Table of Contents note from those 4. Starting on the TOC note, I only get a link to the new test note. What’s really interesting is the duplicated notes are entirely missing from the vault (but the originals did come over in an earlier trial). Obviously I have some things to play with before moving to exclusive Obsidian use. Am I missing a setting? I’ve tried “Add ‘md’ extension of internal links” and done it without.

UPDATE: The welcome screen appears before the program is actually finished installing. ORIGINAL: In a separate issue - when I run Yarle it appears to start up normally. I get the welcome screen, go to step 1 and choose the file I want to convert. When I do, the entire screen disappears, then the Welcome screen reappears. I can choose my file and continue from that point. Not a big deal, just an odd hiccup. I’m on Win10Pro if that helps.

1 Like

Do the tags convert as #tags or [[tags]]?

#tags
Not sure if there is a way to tweak that in the options.

For anyone who is wondering -
After a bit of testing, it looks like the internal links that don’t work for me (in any given folder) are one or more of the following:

  1. what Obsidian would consider a “pretty link” but I think of as an alias in EN
  2. titles that contain a “#”
  3. titles that contain a “/”

EN allows internal and external links to your own notes. External versions still point to “https://evernote.com/shards/…”

What helped was to make a TOC note in EN right before exporting, then looking at it in Obsidian to see patterns.

I’m working through the notes that I’ll be converting (not all) and removing the characters Obsidian doesn’t like. As for the “pretty links” - I think that conversion just doesn’t work.

Not sure how any of this would work starting from EN v10.

1 Like

Hi!

Thank you for raising these issues around the UI, I create issue stories for them on Github and try to fix them!

@akos0215 Thanks for this nice Yarle utility! It seems to be working well for me in Windows except with one strange issue. The output is creating a slash between all of my tags. So for the Evernote tag thisismytag it would be rendered in the markdown as #t/h/i/s/i/s/m/y/t/a/g/. My Evernote tags are in the metadata, not in the note body. I am not changing anything in your tag code block and am not checking the nested tags box or those fields. Thanks.

Hi @obsidvicious ,

huh, it looks like a bug in the regexp part, thank you for reporting it, i check it soon!

Hi @obsidvicious !
By default the ‘’ will be recognized as separator of nested tags(separatorInEN property), and replaced by ‘/’ (replaceSeparatorWith).
But in your case it looks like that separatorInEN is set to empty.
Could you please try to set separatorInEN to '
’? Or if it has already been set,
could you please try to replace the default setting of ‘replaceSeparatorWith’ within nestedTags option by an empty string? It should eliminate the slashes from the generated tag strings.

@akos0215 Thanks for your amazing work on Yarle. I have been an Evernote user since 2010 and I’m excited to move everything over to Obsidian. I have been testing the configuration and templates and everything seems to be working but importing notes with images. I can import notes with attached files like pdf and xlxs. I have not been successful in moving any notes with images into Obsidian. The images end up in resource folder named after the notes, but the notes are not created.

This is a typical log entry.

Conversion started at Sat Jan 08 2022 08:28:10 GMT-0700 (Mountain Standard Time)
Converting note “2017 Study Journal LARGE ATTACHED PNG”…
relative resource work dir: ./_resources/2017_Study_Journal_LARGE_ATTACHED_PNG.resources
absolute resource work dir: C:\Users\derek\YARLE\drh\evernote-notebooks\notes\notes\Obsidian-test_resources\2017_Study_Journal_LARGE_ATTACHED_PNG.resources
resource SWTC3_116112813280.jpg addid in hash 6b11a9fc6d7ff3e4ea7dc5df82558bf2
mediaReference src ./_resources/2017_Study_Journal_LARGE_ATTACHED_PNG.resources/SWTC3_116112813280.jpg added
Failed to convert note: 2017 Study Journal LARGE ATTACHED PNG, {}
Conversion finished at Sat Jan 08 2022 08:28:11 GMT-0700 (Mountain Standard Time)
Note “2017 Study Journal LARGE ATTACHED PNG” converted successfully in 0.313 seconds.

Any suggestions? Thanks.

Hi @scuds !

Could you please send me the full config settings? I need it to try to figure out the problem, it looks really strange, so i have to investigate it further.
The config is logged at the beginning of the conversions. here is my email address if you wouldn’t like to share ot with others:
[email protected]

thanks,
cheers,
akos