Formulas don't render in Canvas notes

Hi guys – I’m using the Linux AppImage v.1.1.8. And I’ve noticed that, in Canvas, any notes that I drag on do not properly render any LaTeX based math. Is it me, or is this happening for others also?

When in the normal Note view, the formulas look fine.


it’s you

Heh… Thanks for pointing that out! Any suggestions on how to make it work?

@WhiteNoise I see you moved this from “bugs” to “help” but, honestly, I think it is a bug – I’ve scoured this forum and done a load of other googling and i can’t find any reference to how to make this work.

Do you have any suggestions?

You didn’t follow the bug report template. If you want to log a bug, please make sure you try all the things, and include all the info requested. Otherwise it will be moved to help where the community can try to help.

As it stands you can reply right here and give more info. If it’s found to be a reproduceable bug, it will still likely get noticed.

I’m not sure what more info to give. When I create a formula on a note it renders fine when I view the note normally, but when I view the note on the canvas, it doesn’t render, and I just see the LaTeX unrendered.

My question was if this was just me (apparently, according to @WhiteNoise it is) but, to be honest, this is not really helping me. I cannot make this work on my setup (assuming it’s just me). I’ve tried different machines, every config change I can think of and it JUST. DOESN’T. WORK.

So can someone please HELP me, rather than keeping on “moderating” me. Is this a bug? Is it a mis-config? Something else?

And, as an aside, I’ve found my welcome to this community, by 2 moderators to be less than welcoming. Both you @rigmarole and @WhiteNoise are not really helping me. You’re pulling me up on process violations instead (not filling in the bug report properly), or making asinine comments like “It’s you”…

I hope my experience as a new member of this community improves from what appears to be a rather poor start. :frowning:

I don’t want to be rude but unless you are a commercial user, you are not entitled to any help.
Our help and the ones from other community member is voluntary.

That being said.
Download and reinstall obsidian. Post a screen recording of this not working in the sandbox vault along with the show debug info output.

I understand your help is voluntary and I’m grateful for that help (such as it is). I am not expecting it as some kind of entitlement, I’m merely requesting it.

I don’t want to be rude.

Then don’t be. Your prior comment was, I think you’ll agree, pretty rude.

In any event, thank you for your now more constructive suggestion now, I will try it.

So here is a screenshot of the problem.

Here you can see that the note in Canvas on the left is not rendering the LaTeX, whereas the vanilla note, when opened, on the right, does.

I am still trying to figure out how to get the logs out – will post those when I figure it out.

I’m not experienced with Canvas, but if you click inside the canvas, it seems to go to edit mode, either for the entire note or for that block you clicked at it. If you hit Esc it goes out of edit mode again, for me.

Does it do that for you, as well?

Debug info:

	Obsidian version: v1.1.9
	Installer version: v1.1.8
	Operating system: #1 SMP PREEMPT Mon Dec 19 13:16:33 UTC 2022 5.15.84-1-MANJARO
	Login status: not logged in
	Insider build toggle: off
	Live preview: on
	Legacy editor: off
	Base theme: dark
	Community theme: none
	Snippets enabled: 0
	Restricted mode: on


I have just played about with that – when I click on the cavas background, I am guessing I go out of edit mode on any card on the canvas. When I do this the formula does not render properly, however, if I click into the note on the canvas, it does go into edit mode, and when in that mode, the formula renders correctly on the canvas.

This feels wrong, as I would expect the formula to be properly rendered when a note is in viewing/reading mode on the canvas but the opposite seems to be happening.

In addition your formula is indented in the source view by four spaces, which seems to render it correctly in the ordinary readinglive preview view, but as a code block within the Canvas.

So if you remove the four spaces in front of your formula, you’ll see it render properly.


That’s it @holroy!! Many thanks.

I was wanting to indent the formula for readability purposes, so, not being a LaTeX expert, I figured just indenting it with some spaces would work, which it did, for the Note view, but clearly not the Canvas view.

I think there might still be some kind of rendering bug here, though, as one would expect the renderer to behave identically when rendering in Canvas or Note mode, but your suggestion has, nonetheless, fixed it.

Again, many thanks!

There is a feature related to this it seems, @rigmarole, but it’s kind of hidden. I’ve used the following markdown to produce the image below:

$E = mc^{2}$

    $sli = \frac { events_{good}} {events_{all}}$

That is four spaces, marking it as a code block, for the lower formula. In the image below I’ve got four views of this note:

  • Upper left: Editing view, source mode
  • Lower left: Editing view, live previes
  • Upper right: Reading view
  • Lower right: Canvas with reading view

So the feature as I see it, is that the editing view with live preview, doesn’t respect that this is actually indented with four spaces, thusly making it a code block.

1 Like

Makes sense, but there is nonetheless an inconsistent treatment here, which makes it a bug not a feature, in my book. If a 4-space-indent is a code block, it should be a code-block always regardless of the view, and never try to render the code as anything but raw code.

In other words, you’d expect your bottom right image to not render the indented formula – the fact that it does looks like a bug to me.

And you are correct and this is a bug. I’ll open a BR for it. it has nothing to do with canvas.


@bradwood Do you now see why posting more information and your actual LaTeX was the key to getting help and finding the bug?

It took you 6 posts before you included any information that anyone could help you with.

That’s why there is a “Bug reports” template automatically filled in when you post in that category. It includes all the info to include and suggestions to try first. Your post didn’t include any of it.

I’m not impressed with you shaming us, because as WhiteNoise pointed out, we’re volunteers in a community where you are not entitled to free support, and we are certainly not ticket agents. But if you ask better questions and include more information, we (the entire community) are always tirelessly willing to help.

Genuinely glad you got your help!

1 Like

Note that there is a difference between enclosing your formulas in one or two dollar signs. The first is meant for inline formulas, whilst the latter is for formulas as their own paragraphs.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.