Force PDF Sync (not recognizing changed)

What I’m trying to do

I have obsidian on my phone, laptop, and tablet.

I want to copy a PDF as an attachment into obsidian → open attachment in 3rd party app → edit (annotations ) save and it syncs so changes are resolved across all versions

So far the change is picked up in the device I make the change to but I can tell that the vault doesn’t recognize the attachment has “changed” so it doesn’t force a sync.

Things I have tried

Embedding the PDF and then changing the page text below. Page syncs but PDF version does not

Force PDF sync
Open PDF in other app

It gets close but those issues are more so about PDFs syncing at all and they do generally (just not re-syncing) or about opening PDF in 3rd party app which I did figure out. It’s just the last re-syncing thats an issue

How do you sync?

If obsidian sync, how big is your PDF? They have a 200MB limit.

If Github, are you pulling changes down on the other device? Can you see the changes on

If a cloud service, do you see the changes in the cloud service?

Obsidian sync and it’s 1MB. I think the core issue is that it doesn’t recognize that the PDF file was edited and doesn’t ask for the sync. (I can see in obsidian sync log that it only syncs changed files)

Weird, cause I used Handwritten Notes while I used Obsidian Sync and it worked fine for me.

What app did you use for handwriting notes?

That’s the plugin.

It uses your built-in editors.

Hello, I have a similar problem so I thought I could as well add it here. I hope it’s not considered a no-content reply.

I have been using the handwritten-notes plug-in for some time on a boox note air 2plus e-ink device now. It’s amazing, but I have problems with synchronization with obsidian sync and displaying embedded pdfs, too, even though the files are not too big for syncing.

I can open synchronized documents via the plugin in the pre-installed pdf program on the e-ink tablet (NeoReader V3.0) and edit them, as well as generate new pdfs to take notes freely. However, embedded pdfs in Obsidian are always displayed empty. Only when I open them again in the pdf app do I see their content. The notes and pdfs are synchronized, but when I open them in Windows, they are empty. At first I thought it might be due to the respective saving paths, but I played around with that and the problem remains the same. Also, it does work the other way around: When I open and edit pdfs on the computer, they are not only displayed in the preview of the embedded pdfs directly in Obsidian, but they are also synchronized with my tablet without any problems. Therefore, it may be due to the NeoReader app. Somebody else mentioned it’s not the best app for syncing here. I have already tried to use a different app on the tablet, but have encountered the same problems. I have also tried to change the app’s setting but honestly I have no idea how to access it’s settings. It could also be due to the storage functions: I noticed that Adobe asks me to save edited pdfs when I close them. Previous versions of the document are then overwritten. This is not the case on my tablet. Notes are saved automatically.

Does anyone have any ideas? I would be grateful for any suggestions.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.