Footnotes vanish

What I’m trying to do

I was just using the footnotes feature provided by the Footnote shortcut. I do not use this function all the time - mostly when I import scientific articles that make use of this feature. So it is a while back since last I used it

What I now realised:

  1. inserting footnotes still works fine
  2. The footnotes are there in editor mode
  3. When I switch to reading mode, the footnotes block at the end will vanish and the reference inside the main text is converted to an ordinary number

Things I have tried

I tried deactivating all sorts of plugins and CSS hacks but the footnotes in reading mode do not come back.

Does someone have an idea on how to fix this?

What I just relaised:

An old text with footnotes works just fine. So, it seems that there is a rendering problem with this particular note.

Any idea on how to check for a line with problematic formatting that breaks the function properly displaying the footnotes?

Ok, this is weird. It seems that somehow, inserting one more footnote after the first one will not insert a proper linebreak between the two footnotes.

This apparently leads to all footnotes after number one not being displayed in reading mode.

Also, this happens with every next footnote again.

Manually inserting linebreaks after each footnote at the bottom fixed the problem.

Is this a plugin you are using, or just the regular syntax in Obsidian? You capitalized “Footnote”, so I wasn’t sure if that was a plugin.

It might help to show some examples of your syntax. A screenshot. Or paste your Markdown between triple quotes:

Your example Markdown here

Thanks for you reply. I am using this plugin

to add foonotes quicker via the editing toolbar.

It is weird since the plugin always worked nicely but somehow now seemed to keep out missing spaces in between footnotes. As soon I manually added them, the rest of the footnotes magically appeared …

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.