Footnotes show in plain text, no links in preview mode

My Problem

When I add more than 20 footnotes ( [^21] ) the footnotes from 20 onwards appear as plain text in preview mode. In edit mode they work fine, though. Whet I export to PDF, the footnotes from 20 onwards appear as plain text, with no links to the corresponding reference. I don’t know how to correct that.

Here are some screenshots of my document, in preview mode, the first two in the body of the text, the last two in the reference section. Until footnote #19 everything is ok, but then I have problems.



Hey there! I found that if instead of using [^1] (normal footnotes) you use ^[] (inline footnotes) works better.

Thank you @roijab
But I would like to maintain the normal footnotes. I wonder if my problem have anything to do with de Footnote Plugin. I use the Tidy Footnotes Plugin to reorder them.

Shouldn’t that be easy to test? Just disable that plugin, and see if your issues resolve themselves.

And I reckon, you’ve already tried restarting obsidian?

@holroy Thank you. Yes, I disabled the plugin and restarted. Nothing changes.

Have you also tried in the sandbox vault and see the same behavior there? Try with some simple list of 25 footnotes, and see if it’s reproducible in there.

If so, you might have a found an error in the live preview rendering (which indeed is different than the reading view rendering).

I tried on mobile with 25 footnotes, but it worked just fine. However, mobile and desktop are different.

Did you state which version and installer you are using?


So now I’ve also tried on desktop, and no issues.

Could you please enclose the actual markup for your footnotes, which are troublesome? Both the reference in the text, and the definition of your footnote.

And enclose all your text in four backticks, to ensure proper formatting in the forum posts.

(Are you sure it’s not something wonky with that 20th footnote definition of yours? Have you tried removing either of the 19th, 20th and/or 21th footnote, and see if the others then start behaving? )

Don’t know if this will help with the issue or not, but the installer and Electron version are out of date and in need of updating:

This sample text works locally in Obsidian (1.1.15) on macOS and when exported to PDF. Copied here for anyone else who wants to try it for themselves. (Use ‘paste and match style’ to retain the layout.)

Here's a simple footnote,[^1] and a second [^2], third [^3], fourth [^4], fifth [^5], sixth [^6], seventh [^7], eighth [^8], ninth [^9], tenth [^10], 11th [^11], 12th [^12], 13th [^13], 14th [^14], 15th [^15], 16th [^16], 17 [^17], 18th [^18], 19th [^19], 20th [^20], 21st [^21]

[^1]: seen
[^2]: mean
[^3]: bean
[^4]: lean
[^5]: keen
[^6]: yin
[^7]: gin
[^8]: grin
[^9]: din
[^10]: find
[^11]: bind
[^12]: kind
[^13]: rind
[^14]: much
[^15]: such
[^16]: cow
[^17]: now
[^18]: blue
[^19]: red
[^20]: ache
[^21]: bake

Number 20 should have been “Shake.”

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.