Footnotes not working v2

Hey, guys,

I’m running Windows 10 Pro with Obsidian v0.7.3, but I’ve had this issue since I first noticed it in 0.6.7.

I have zero plugins enabled and am not using Custom CSS and still have this issue.

Footnotes don’t work. In Edit Mode, when I type “[1]” and then with the footnote down below, I get what looks like a live preview where it recognizes it as a link and turns the 1 into a superscript, but when I switch to Preview Mode, I can’t click on a link and it reverts back to not even looking like a link.

And I’ve tried separating them so one’s at the top of the page and the other is at the bottom, but no dice.

I’ve already checked the docs and copied the format used there and can’t even get that to work.

Thanks for any advice anyone has!

PS Reposting because it was accidentally put into the graveyard, but isn’t fixed.

Again, you are not using the correct notation for footnotes.

Here's a simple footnote,[^1] and here's a longer one.[^bignote]

[^1]: meaningful!

[^bignote]: Here's one with multiple paragraphs and code.

Hey, WhiteNoise,

Thanks for trying to help! I appreciate it. When I copy and paste the footnotes, like [^bignote] and [^1] from the help docs and paste it into my vault, it still doesn’t work. So, I think I’ve got something other than my simple error.

copy paste what I wrote in your obsidian; then post a screenshot of your result. Because in your current screenshot the notation is wrong.

Ok, got it. It’s the colons. I didn’t realize when I copied it over to my vault and accidentally left those out. Here’s an image of a working link with colons and the broken one like I had before.

The issue is down below you have to put a colon. I didn’t know that. I thought my notation was all within the brackets and didn’t understand how it was wrong.


Thanks for copying and pasting that. That helped.

Feel free to move to graveyard now. :slight_smile:

1 Like