Footnotes not working again

Issue
For some reason [^1] style footnotes render with the caret symbol, and inline footnotes don’t seem to work at all.

Not quite sure, what you’ve written since it doesn’t work in your world, but footnotes do seem to work as intended for me, so you might need to double check what’s the difference between the following text and your text.

A footnote [^1]. It leaves the caret in for some reason.
Inline footnote ^[Yes], could be working ^[or not].

[^1]: Does work...

Produces the following, with source view to the left, and reading view to the right.

If your Obsidian differs, you might also want to include which version of Obsidian you’re using.

Regards,
Holroy

I have the same problem. After reading and following the scant instructions in the online help (re-read and tried many times), the caret shows in the content, but never turns into a link BUT the footnote text, which I placed immediately below the content, does become a link that goes nowhere. Very odd behaviour.

Downloaded Obsidian a couple of days ago (Windows10).
Is there are setting that needs to be tweaked?

So far, I’m finding Obsidian rather frustrating. Looks “nice” and promises simplicity, however examples and instructions are loaded with jargon.

I can’t reproduce your error. And I have a gazillion plugins installed too.
Did you try in the sandbox vault?

Produces the following, with source view to the left, and reading view to the right.

I was struggling with this same issue but after reading @holroy comments, I realized that the markdown doesn’t automatically render the footnotes in edit mode, but render correctly after switching to read mode.

3 Likes