Footnotes not working again

For some reason [^1] style footnotes render with the caret symbol, and inline footnotes don’t seem to work at all.

Not quite sure, what you’ve written since it doesn’t work in your world, but footnotes do seem to work as intended for me, so you might need to double check what’s the difference between the following text and your text.

A footnote [^1]. It leaves the caret in for some reason.
Inline footnote ^[Yes], could be working ^[or not].

[^1]: Does work...

Produces the following, with source view to the left, and reading view to the right.

If your Obsidian differs, you might also want to include which version of Obsidian you’re using.


I have the same problem. After reading and following the scant instructions in the online help (re-read and tried many times), the caret shows in the content, but never turns into a link BUT the footnote text, which I placed immediately below the content, does become a link that goes nowhere. Very odd behaviour.

Downloaded Obsidian a couple of days ago (Windows10).
Is there are setting that needs to be tweaked?

So far, I’m finding Obsidian rather frustrating. Looks “nice” and promises simplicity, however examples and instructions are loaded with jargon.

I can’t reproduce your error. And I have a gazillion plugins installed too.
Did you try in the sandbox vault?

Produces the following, with source view to the left, and reading view to the right.

I was struggling with this same issue but after reading @holroy comments, I realized that the markdown doesn’t automatically render the footnotes in edit mode, but render correctly after switching to read mode.


In Obsidian 1.1.9 the following works

A footnote follows ^[the first footnote] ,
and then another ^[another note],
and so on. ^[…]

The result is only shown in view mode.


Note the difference between the two syntaxes as showcased here:

A footnote follows ^[A footnote],
and then another [^B],
a copy of the first ^[A footnote],
and a copy of another [^B]

[^B]: Another footnote

Which renders as:

The duplicated ^[A footnote] is not recognised as a copy in the footnote references, whilst the duplicated [^B], is recognised and got the two backlinks in the references, and the counter in the normal text.

I had same issue, which led me here. What fixed it for me was moving my footnote text to the bottom of the page, after a lot of other text. Initially I had written the footnote text ([^1]: footnote ref) on the line immediately after my footnote. Of course, had to switch to reading mode too.

Hope this helps!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.