Font not changing in Editor View

Things I have tried

  • Text font in Settings → Appearance - Attempted several different fonts, no change
  • Minimal Theme Settings → Editor Font - Attempted several fonts, and no font when using other methods, no change
  • CSS Snippet - Attempted several font changing css methods found here on the forums, no change
  • Attempted all above changes while also toggling on/off and uninstalling individual community plugins.

What I’m trying to do

I am attempting to change the font in the Editor View but none of the above mentioned methods are working. The Settings → Appearance → Font works for all fonts EXCEPT Editor View. This problem does not exist in a separate Vault with the same plugins installed.

1 Like

I have the exact same issue!

If you find a solution, be sure to post it. It’s boggling my mind. It’s probably something really simple, too.

I’ve searched high and low like you and tried every possible solution I could find. Mind boggling indeed! Of course I will post it if I find something that works :slight_smile:

A month or two ago, I had a similar thing come up. The solution was make sure all plugins were up to date (I never did figure out which one was causing the problem) and restart Obsidian. (I may have also restarted the whole computer in the process, I don’t recall.) I’m guessing you’ve already tried this, but throwing it out there just in case.

1 Like

Did indeed try that, but in my case that didn’t help :unamused: and unlike TS, I have it in ALL my vaults.

Yeah, I’ve attempted all of that as well. Thanks though!

UPDATE: I have fixed my issue, though the reasoning behind the fix is still a bit perplexing. In my previous attempts at getting the font changed, I had attempted switching off the Minimal theme entirely and reverting to the base Obsidian theme, with no success. However, today I switched to an entirely different theme, really just looking at themes, not even worrying with the font issue, and the font changed! Switching back to Minimal theme does NOT break it again. So something to try, switch themes around a bit!


Still doesn’t work for me. I have a Xiaomi mobile, bought it in China. All the font issues are a bit tricky, different from other devices.

I tried to change the fonts in Obsidian your way. With the Minimal theme no changes, trying to change the fonts in the appearance tab crashes Obsidian.

Would be nice with Minimal theme to have a drop down menu to choose the fonts from, not to add the names by hand.

Well, I was on my way to try what you did, switching themes…saw the update button or minimalist and thought, let’s do that first…bammm, all of a sudden my editor font is back to what I want it to be!!

And yes… I DID update all the previous times. So I think, the developer of Minimalist theme has read our discussion here and fixed it :wink:

Try updating your theme…worked for me (today…not all the previous times I updated!)

1 Like

It started working again after the last update of Obsidian (Insider build), I didn’t change anything else, so I still don’t know what caused this…sorry I can’t tell you more :woman_shrugging:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.