Flickering when zooming in medium sized canvas (hardware acceleration)

Steps to reproduce

  1. Create a medium to large sized canvas
  2. Zoom or pan in the canvas
  3. Observe flickering of the whole UI

Did you follow the troubleshooting guide? [Y/N]

Yes, sandbox vault, default theme, restricted access, no plugins.

Expected result

Normal zooming and panning (it worked flawlessly before).

Actual result

Whole UI is flickering.


Obsidian version: v1.4.16
Installer version: v1.4.16
Operating system: Darwin Kernel Version 23.0.0: Fri Sep 15 14:41:43 PDT 2023; root:xnu-10002.1.13~1/RELEASE_ARM64_T6000 23.0.0
Login status: logged in
Catalyst license: insider
Insider build toggle: on
Live preview: on
Legacy editor: off
Base theme: light
Community theme: none
Snippets enabled: 0
Restricted mode: on


Additional information

When the window is small enough the flickering stops (even for large canvases). Also, when I disable hardware acceleration in the settings the flickering stops. However, without hardware acceleration the frame rate quickly deteriorates.

Video with hardware acceleration enabled: With Hardware Acceleration · CleanShot Cloud

Video with hardware acceleration disabled: Without Hardware Acceleration · CleanShot Cloud

1 Like

What exactly is your computer and OS version?

This looks like something beyond our control.

MacBook Pro M1 Pro, macOS Sonoma 14.0.
I guess I could update to macOS Sonoma 14.1.1, didn’t notice that there were new updates.

It seems to be related to Electron apps though, got similar effects in VSCode lately. But of course it might also just be my specific setup.

Updated to newest macOS version, reinstalled Obsidian with newest installer. No changes.

But as I saw the same effects with VSCode I suspect that it is not directly related to Obsidian.


I’m seeing the same thing, I have the same setup.

1 Like

I’m noticing the exact same behavior. Flickering is even more when obsidian is running on an external 4K LG monitor.
Macbook Air 2020 M1, Sonoma 14.2.1, Obsidian 1.4.16.
When hardware acceleration in obsidian is disabled, it works fine, but way slower scrolling.
I’m working with a canvas with 120kb in size constantly.

Same behavior - M2 MacBook Air, Sonoma 14.2.1, Obsidian 1.4.16

Like others have said, disabling hardware acceleration fixes the issue, but that makes the app unsable.

Here’s a video of what the issue looks like on my end:

1 Like

Disabling Appearance > Translucent window appears to solve flickering without having to disable hardware acceleration. (MacBook Air M1, Sonoma 14.2.1)