Flashing bar when typing

Hello all! I am very new to using Obsidian and I’m not sure if this is the best place for this problem, so any advice you have would be greatly appreciated. I did a quick search throughout the forum and couldn’t find another similar post.

I have v0.11.3 for Mac. Whenever I type any text in a note, there is a black bar that appears one line below with each character I type. The bar immediately disappears and is only visible for a split second, but it’s giving me a headache since it happens with every key stroke and ends up having a flashing effect. It does not happen when I title a note or folder, and it does not happen when I delete text. I have tried typing with no theme and with a theme, in both light and dark modes, and this bar always appears. It seems to extend from just below my text all the way to the right side of the window.

Any advice is greatly appreciated! Thank you so much.

Hi @hmw1031, that sounds annoying :frowning: I haven’t heard of an issue like that before. Do you mind creating a screen recording so we can better see what you mean?

A few ideas I had for diagnosing the issue:

  • Do you have an external monitor plugged in? In the past, I have seen rendering issues that go away by unplugging your external monitor and plugging it back in.
  • Also, does the issue persist after restarting your computer?

Hi @liam

Thank you so much, and my apologies for the delay!

Here is the video: https://youtu.be/V_P8AHonzDo

I don’t use an external monitor, this is just on my Macbook laptop.

I also tried restarting my computer, this video was taken after I restarted.

Thanks again!

1 Like

this is really strange, have you noticed this happening anywhere else outside of Obsidian, or does it only happen when you type in Obsidian?

If you determine it’s just Obsidian It’s worth trying to see if a community theme, or community plug in could be causing the issue.

You can test this in a few ways

Create a brand new Obsidian vault


Open the help vault


And test writing to see if the problem keep happening. In the help vault or in a new vault there are no plugins activated or themes, let us know if that solves it

1 Like

In Obsidian version 0.11.7 there will be a new feature. It’s still an insider build for now.

There is now an option to disable GPU acceleration, especially helpful for those experiencing kernel panics and graphical glitches on MacOS.

I wonder if it is a GPU glitch. What graphics card is in your Macbook? What version of MacOS?


@santi @rigmarole Thank you so much for your help, and my apologies for the delayed reply! I’m still having the issue and will try to answer all of your questions here.

I have never noticed this happening anywhere outside of Obsidian.

I don’t use any community themes (I’ve tried a few, the same problem happens regardless). I also don’t use any community plug-ins. I’m still new to using Obsidian and wanted to get this resolved before I add in all this extra stuff!

I just tried creating a new Obsidian vault - same issue.
I then tried using the Help vault - same issue.
I then tried turning off “Hardware Acceleration” (to disable GPU acceleration) and relaunched Obsidian when prompted - same issue.

I just upgraded to 0.11.9 today.

I have a 2015 Macbook Pro with OS X Yosemite Version 10.10.5. I know this is very outdated but I’ve had trouble upgrading iOS further since my Macbook is on the older side. For graphics it says Intel Iris Graphics 6100 1536 MB. (I really know very little about computers, so if this isn’t the correct information just let me know!)

Please let me know if you have any other advice!! Thank you!!

Hey @hmw1031 sorry to hear you are still having issues. I know how frustrating these things can be.

It’s really strange and it’s really tricky to know what’s causing it.


Something that might helps is not just to upgrade to Obsidian’s newest version, but to uninstall Obsidian an reinstalling it from scratch.
(deleting the app and going to obsidian’s landing page to reinstall it)

There seems to be issues if the Installer version is too old. You can see this in Settings > About


If that doesn’t work, like you said perhaps a mac upgrade to something like Catalina might help. I also own an old mac (2013 imac which I managed to update to Catalina)and I know how tricky it can be to upgrade sometimes for older macs, give this a try if you manage to figure it out, since I do think this might solve things for you.

Hope that helps!

Hi @santi,

Thanks so much for your continued help. I did just try to reinstall Obsidian, but no luck. I’ll work on getting my Mac OS updated and hope that works!

Thanks again,

1 Like

Hey Hannah, sorry to hear you haven’t had luck with this yet. Keep us posted


I finally got around to updating my Mac OS and that solved the issue! Thanks again for your help!


1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.

that’s great to hear, happy to know it got solved!