Find inside note broken when clicking on a word

(First I thought this had to do with Vim mode, but it also seems broken without Vim mode enabled)

Steps to reproduce

  1. Open the Sandbox Vault
  2. Click on the “o” from the sentence “First of”
  3. Click on some whitespace (in Vim mode the letter “o” should now have a red box around it, but it’s basically CodeMirror placing the cursor on that position, breaking up the search text)
  4. Find the text “First of” with the Find in document function (e.g. Cmd-F)

Did you follow the troubleshooting guide? [Y/N]


Expected result

The search term “First of” should be found

Actual result

Only the text "First " can be found, no further matches. Probably because CodeMirror is breaking up the elements underneath when placing the cursor.


Obsidian version: v1.5.3
Installer version: v1.4.16
Operating system: Darwin Kernel Version 23.2.0: Wed Nov 15 21:53:18 PST 2023; root:xnu-10002.61.3~2/RELEASE_ARM64_T6000 23.2.0
Login status: logged in
Catalyst license: vip
Insider build toggle: on
Live preview: on
Base theme: adapt to system
Community theme: none
Snippets enabled: 0
Restricted mode: on


1 Like

I’m able to reproduce this. I changed “Search” in the title to “Find” to match the feature’s name.

Thanks @CawlinTeffid - hopefully this can be fixed in a future release!

  1. Does it happen in the sandbox vault?
  2. Does it happen in source mode?
  3. Does it happen here ?
  4. Does it happen here ?

I can’t check the others right now, but 1. Sandbox is a yes.

2. It does happen in Source Mode in the Sandbox.

3 & 4: I don’t see a “Find…” feature on either of those pages, so can’t test. I tried with desktop Safari’s built-in Find and that worked, FWIW.

Search how?

“Find…” in page, not the global search.

@WhiteNoise as far as I can see it only happens in the CodeMirror view (Live Preview) as I’m fairly certain it happens when CM6 ‘draws’ a cursor in the selected text and ‘breaks up’ the text in 's for the matched and non-matched parts (you can check in the Console)


Weird. This isn’t a vim bug. It also happens when vim mode is disabled.

This will be fixed in v1.5.6

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.