Files missing from iPad with Obsidian Sync

Once you’ve done the above, delete everything above this line.

Steps to reproduce

After creating a new remote vault on Mac, I set up Obsidian Sync on both a Mac and iPad. No errors were given in the sync log. However, some files are not showing on the iPad Vault.

Did you follow the troubleshooting guide?

Yes,

Expected result

I expect to have all the synced files available on both devices.

Actual result

Some files are missing from the iPad vault.

Environment

SYSTEM INFO:
Obsidian version: v1.5.12
Installer version: v1.5.3
Operating system: Darwin Kernel Version 23.4.0: Fri Mar 15 00:11:05 PDT 2024; root:xnu-10063.101.17~1/RELEASE_X86_64 23.4.0
Login status: logged in
Catalyst license: none
Insider build toggle: off
Live preview: on
Base theme: light
Community theme: Minimal v7.5.4
Snippets enabled: 0
Restricted mode: off
Plugins installed: 10
Plugins enabled: 9
1: Excalidraw v2.1.4
2: Editing Toolbar v2.4.14
3: Handwritten Notes v1.3.5
4: Ketcher v0.1.4
5: MathLive v1.2.0
6: Minimal Theme Settings v7.5.0
7: Omnisearch v1.22.2
8: Smart Typography v1.0.18
9: Style Settings v1.0.8

RECOMMENDATIONS:
Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.


Additional information

I made sure the vault is not stored in iCloud or any other third-party sync folders. The only files affected seem to be PDFs; some PDFs sync perfectly fine, while others don’t. I have tried duplicating or editing files on the Mac; they did not appear in the iPad vault.
Everything is running on MacOS/iOS, so there is nothing attempting to sync between different operating systems.
I also tried disconnecting both the Mac and iPad from the remote vault and reconnecting them after restarting Obsidian.
The files do not appear in the Files application on the iPad where the rest of the Obsidian files are stored.


This is the vault folder on the Mac (including all files)


This is the same vault folder on the iPad.

Are the pdfs bigger than 200 mb? There’s a limit on the file size.

No, the files are 10-20MB.

Which sync plan did you buy?

I just double-checked and realized I had the plan with the smaller file size. I upgraded the subscription, and hopefully it will sync properly once the change is processed!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.