Files mass deleted?

Hi! I opened Obsidian this morning and nearly all my files have been deleted. When I open snapshots, its appears I do have stuff there… but I’m trying too figure out what happened.

Are there logs that I can look at to see what happened? Thankfully I just started this vault like a week or two ago, but this is still very disconcerting. I’m on version 0.13.12

Appreciate any suggestions for mass-restoring things from snapshots as well.

That’s bad, sorry to hear that.

To try and figure out what happened:

  • Most importantly, what sync solutions are you using? (Including if your vault is stored in a folder that your operating system automatically syncs, like OneDrive or iCloud.)
  • What community plugins do you have installed? (If you aren’t willing or able to list them all, just take a look through them and think about which ones might be related to editing or syncing your notes.)

Regarding a log. I’m not sure. I think the only log you would see is if you were using Obsidian Sync. Otherwise if another tool changed your files, Obsidian would remain unaware of that. (As far as I know. If I’m wrong, hopefully someone else has an answer for you.)

Regarding mass-restoring. I think this is already a feature request. Right now I think the only mass-restore you can do is if you were keeping good incremental backups somewhere. (Something I highly recommend everyone should do.)

I have my vault in iCloud, so that’s all I’m using to sync.

I tried my best to discern if it was Obsidian that deleted the files or something else, and haven’t found any leads. Last time I had it open was Friday, and then opened it today, and stuff was gone!

Only community plugins I’m using are Dataview, Mind Map, and Natural Language Dates. Of those maybe Dataview would do something to my files?

I’m no authority on iCloud, but doesn’t it have some automatic features where it removes stuff that hasn’t been used in a while? (removes locally, and just moves it to the cloud.) I wonder if it may have been something like that. And if so, I wonder if you can disable that.

If you look in Finder (before you restored the files) was there a little cloud icon beside the files maybe?

I personally don’t trust iCloud for my vault. I’ve seen enough people having issues with it. (That’s not to say it doesn’t work in most situations… I just don’t know.)

Yeah that’s a valid critique re: iCloud. This is the first time I’ve run into something like this with it though! And the little cloud icon isn’t even there (I know what you’re talking about there) - the files are just gone.

I’ll certainly set up a separate backup system going forward - just really wish I could figure out if this was something caused by Obsidian or not.

1 Like

You need to log in to on the web, go to Settings on there, and under advanced you will find file recovery. See if your missing files are there. If they are, you’ll be able to retrieve them. If they’re not there, you will have to open a ticket with Apple.

1 Like

That was a great suggestion @gestaltist, unfortunately none of my Obsidian files are showing up there or in “recently deleted” on either. Admittedly I’ve never tried to use those features so I’m not sure how readily files DO appear there.

I’ll start restoring some files via the snapshots feature, set up a new backup through automator or something, and go from there. :crossed_fingers:

1 Like

It did happen to me once but not with Obsidian. I.e., iCloud deleted a few files and they were not retrievable in any way for me. Apple engineers were able to roll back iCloud to an earlier state and I got back at least some of the files.

If you have snapshots, that’s probably better, though.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.