Files are opening empty

Steps to reproduce

I open an existing file. I see the file title in the main window but not in the tab. The file seems empty. I try to open a differnet file, nothing happens. I have Obsidian Sync so I open the restored versions where I do see my content but I cannot restore them (it says it is already restored)

see this loom video: Loom | Free Screen & Video Recording Software | Loom

this happens on two vaults I am using.

Did you follow the troubleshooting guide? [Y/N]

I tried using the sandbox vault and it didn’t have that problem.

Expected result

file to open…

Actual result

file opens empty


Obsidian version: v1.5.4
Installer version: v1.4.13
Operating system: Darwin Kernel Version 23.3.0: Wed Dec 20 21:33:31 PST 2023; root:xnu-10002.81.5~7/RELEASE_ARM64_T8112 23.3.0
Login status: logged in
Catalyst license: insider
Insider build toggle: on
Live preview: on
Base theme: dark
Community theme: LYT Mode v1.9.1
Snippets enabled: 4
Restricted mode: off
Plugins installed: 33
Plugins enabled: 23
1: Style Settings v1.0.7
2: Advanced Tables v0.21.0
3: Advanced URI v1.40.0
4: Canvas Mindmap v0.1.9
5: Dataview v0.5.64
6: ExcaliBrain v0.2.12
7: Excalidraw v2.0.20
8: Footnote Shortcut v0.1.3
9: Hover Editor v0.11.17
10: Minimal Theme Settings v7.3.1
11: Natural Language Dates v0.6.2
12: Note Refactor v1.8.2
13: Omnisearch v1.21.1
14: Omnivore v1.9.2
15: QuickAdd v1.6.1
16: Readwise Official v2.0.1
17: Remember cursor position v1.0.8
18: RTL Support v1.1.2
19: Simple Embeds v1.15.0
20: Strange New Worlds (SNW) v1.2.5
21: Templater v2.1.3
22: Typewriter Scroll v0.2.2
23: Zotero Integration v3.1.7

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

I’m not sure if this is related but I’m also having an empty files problem. For me notes can suddenly become empty. I think it’s when I switch back to the app having switched to another app. iCloud vault on Macos 14.2. It seems to be a recent problem so I’m going to update OSX to the latest patch.

Where are your notes stored? Are you files local? are you using some cloud storage?

Did you try default theme and restricted mode on before opening the bug report?

@blahblah1 your issue sounds like: Note content disappearing on Mac OS Sonoma 14.0 - #11

It seems to be fixed by turning off Optimise Storage in iCloud settings and/or setting the file to Download Now via Finder.

For the Obsidian team: it’s really easy as a new user to end up getting hit by this bug and if users are keeping any value files in Obsidian it’s hard to understate how scary this is. Is there any way you can re-write your file handling/iCloud code to be more solid? I just spend an hour or two looking at this and while I’m very happy there’s a workaround it does seem to be fundamentally “an Obsidian thing” - are you using the right APIs for iCloud?