File version rolled back after turn on Obsidian sync

My girlfriend has been written her application proposal in Obsidian (v0.12.16) for mac os (12.0.1). Her laptop has not been syncing to the remote vault after reinstalling the ios system and applying the ios time machine weeks ago. Today, after she connected to the remote vault again, her proposal file rolled back to the previous version. We tried to recover the file, but there was only one version in the file history which was the old one.

Please give us some help in recovering the file. She has put a lot of effort into the proposal and the submission deadline is close.

We tried the plugin file recovery. The weird thing is that the latest version was a week ago. Still, we are not able to find the latest local version which was missing after turning on the sync.

It seems that the file recovery plugin does a decent job. We have found a version that is not very far from the latest one. The design of Obsidian is great.
However, the file rolling back after turning on Obsidian Sync could be a potential bug. I’m not sure about the exact cause of the problem because my girlfriend was not fully aware of the process she did.
All I can tell is that the file did roll back to an old version and Obsidian Sync seems to be blind to the local file (which is indeed the latest one).

Well, it’s possible that she modified both files. So figure out which one is the old and which one is the new one is not that straightforward.

You shouldn’t have to resort to file recovery.
I am surprised that the sync history only contained 1 version. That is really strange. Did you rename or delete this file?

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.