File Corruption (laptop? multi-machine sync?)

(my first issue,) I have lost a few files recently - filled with null characters. I’m a new Obsidian user and love it, but having files corrupted is a show stopper for me and I’ll go back to Evernote if I can’t get to the bottom of it.

I have two vaults, both syncing. The vault with corruption has two differences from the other; 1. I use it on two machines instead of 1 and 2) it’s a laptop (no battery dead crashes) which often suspends and resumes.

Another potential clue – the files had attachments and the attachments are also corrupted.

I’ve turned on file recovery and increased the time for retention, which should help in the future, but would rather think of restoring from backup as for exceptional cases like power failure or HW crashes.

I have no idea when these files first became corrupted.

Steps to reproduce

I don’t know what caused the problem. The result is a file filled with null characters.

Expected result

Sorry, it was a file filled with useful data (which is what I expected when I opened it again), now it is filled with null characters

Actual result



  • Operating system: Windows 10 Enterprise 21H2 19044.2006
  • Debug info:
    Obsidian version: v0.15.9
    Installer version: v0.15.9
    Operating system: Windows 10 Enterprise 10.0.19044
    Login status: logged in
    Catalyst license: insider
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: none
    Snippets enabled: 0
    Restricted mode: off
    Plugins installed: 1
    Plugins enabled: 1
    1: Tasks v1.15.0

Additional information

This happens when the file writing on disk did not go well.

Obsidian Sync also has a file history for markdown files.

I use it on two machines instead of 1

What does this mean? Is the vault in external drive and you use it in multiple computers?

About file writing on disk not going well – how is obsidian different that my other applications? I have had no other write problems to disk on these machines.

About two machines, I mean that I have two separate computers (each with their own disks) that stay synced through obsidian sync.

Thanks for the comment about the obsidian sync history – I’ll take a look and see if I can find those.

It isn’t.

Not sure if this ever got solved for OP, but I’m also seeing some files being replaced with  with the Android app. It happens on some files and not others–not sure why. But it particularly seems to affect brackets, bullets, and headings. E.g.,

## Main
- Continuing
    - [ ] [[Noninvertibility]]


​ Continuing

Note here that Main and ​ Continuing were actually both preceded by U+200B “zero-width space”. This seems to only happen for bullets/headings that have sub-bullets/headings, so maybe it has something to do with the rotating fold/unfold caret.

Also, I haven’t checked them all, but I think all the are U+FFC “object replacement character”.

I suspect this is an interaction between Samsung’s keyboard and the unicode styling elements used by the WYSIWYG “Live Preview” editor, so I’m disabling Live Preview on that device. (Options > Editor > Default editing mode > Source mode).

I also am using a non-Obsidian sync method (syncthing) on these files, but I don’t think that’s the problem (the corruption happens the moment I open the file for editing in Obsidian). The files are also on an SD card, but I don’t really think reads/writes there are a problem either (they aren’t generally a problem there, for either most Obsidian files, or for other apps).

I’ll continue to watch and see if disabling Live Preview fixes it for me, and after updates cautiously commit files to git and then try re-enabling it.

I don’t use custom themes, and that device/vault had the custom plugins “Calendar”, “Dataview”, “Excalidraw”, “Periodic Notes”, “Templater”, “File path to URI”, and “Heatmap Calendar”; and I’m now disabling the last two.

In source mode editor, I still get corruption due to indents, but not brackets. In source mode with the Gboard editor, I still get indent corruption, but it’s just the zero-width spaces, not the object replacement characters.

This problem only seems to happen on my Samsung Tab S7FE, not my Pixel 6. @WhiteNoise , do you think I should open a new topic about it? It’s preventing me from editing any notes in Obsidian on my tablet; I have to locate and modify the file in another app. And so Excalidraw with S-pen, a major draw of the tablet, is totally disabled.

Looks like this issue is what I’m experiencing. I’ll copy my comments there.

I am also experiencing a similar problem on my android tablet (Samsung Galaxy Tab S8). When I switch into preview mode, bullets and other markdown are replaced with ‘•••••••••’. This happens as part of a loop, so if I don’t navigate away, the number of special characters continues to increase. The • characters are only added to the section of the file that I’m previewing - above and below seem to be fine. I do not get this issue on any other devices.

Edit: Yeah, it’s this issue - [Bug] Text editing gets corrupted sometimes on Android - #3 by photvedt.