Failed to Run User Script in Obsidian on Ubuntu 23.04

I recently migrated my Obsidian workspace from Windows 11 to Ubuntu 23.04, and I’ve been encountering an issue with the QuickAdd plugin. Despite a seamless transition to Ubuntu and successful migration of my workspace, I am unable to run user scripts through the QuickAdd plugin.

Whenever I try to add a movie via QuickAdd, I receive the following error message: “QuickAdd: Failed to run user script.” I have attempted to create a new macro using the new API, but unfortunately, it doesn’t resolve the problem.

I suspect that there might be a permission issue preventing the execution of scripts within Obsidian on Ubuntu. In an attempt to troubleshoot, I have already provided execution permissions to the relevant files, but the problem persists.

To provide further context, I have installed Obsidian on Ubuntu using Flatpak. I have not encountered any other issues apart from this script execution problem.


Could be Flatpak.
Can you install .deb?

1 Like

Buddy, .deb version is not working properly.


1 Like

Haven’t tried it before. After I tried, got the same error.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.