Failed to load PDF document error when opening PDFs in Obsidian

Steps to reproduce

I opened the PDF in Obsidian! Same result whether I drag+drop into Obsidian or in Finder.

Expected result

Seeing my PDF!

Actual result

I receive an error message, see below!:


  • Operating system: macOS Monterey Beta 12.4; 2019 MacbookPro

  • Debug info:
    The same thing happens when plugins are all disabled or I am in safe mode! The same thing happens in other vaults.

	Obsidian version: v0.14.6
	Installer version: v0.14.5
	Operating system: Darwin Kernel Version 21.5.0: Mon Mar 28 19:53:00 PDT 2022; root:xnu-8020. 21.5.0
	Login status: not logged in
	Insider build toggle: off
	Live preview: on
	Legacy editor: off
	Base theme: dark
	Community theme: Minimal
	Snippets enabled: 0
	Safe mode: off
	Plugins installed: 23
	Plugins enabled: 22
		1: Annotator
		2: Better PDF Plugin
		3: Better Word Count
		4: Citations
		5: Dictionary
		6: Enhancing Mindmap
		7: Hider
		8: Icon Folder
		9: Mind Map
		10: Note Refactor
		11: Paste URL into selection
		12: Outliner
		13: PDF Highlights
		14: Recent Files
		15: Table of Contents
		16: Supercharged Links
		17: Tag Wrangler
		18: Todoist Plugin
		19: Templater
		20: Minimal Theme Settings
		21: Style Settings
		22: Ozan's Image in Editor Plugin

	Custom theme: for cosmetic issues, please first try updating your theme to latest. If still not fixed, please try to make the issue happen in the help vault or disable community theme and snippets.
	Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the help vault or disable community plugins.

The same thing happens with all of the PDFs I try to open — from the biggest OCR’d books to single-page scans. I couldn’t find any posts on this or solutions online! Any advice or fixes appreciated. :slight_smile:

There are other posts on the form about this. Are you sure you searched?

Download and reinstall obsidian from the website.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.