Failed to embed webm file as video

Steps to reproduce

  • Embed webm file in a note.
  • Use the ![filename.webm] syntax.

Expected result

render video preview like so:

Actual result

render audio clip like so:


  • Operating system: Windows10
  • Debug info:
    Obsidian version: v1.0.0
    Installer version: v0.14.15
    Operating system: Windows 10 Home 10.0.19044
    Login status: not logged in
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: none
    Snippets enabled: 0
    Restricted mode: on

Additional information

I had this issue after updating Obsidian to version 1.0.0.

1 Like

Download and reinstall obsidian. Does it happen with all WebM or just this one.

I can confirm this issue with v1.0.0 on Linux (Flathub release). Before today’s update it was working without problems.

I deleted all the config (~/.var/app/md.obsidian.Obsidian) and the problem still exists.
The element is rendered with <audio>...</audio> instead of <video>...</video>.

will be fixed v1.0.1

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.