Extremely low resolution in Obsidian 1.4.x on Linux with Wayland

Steps to reproduce

  1. Install/update any Obsidian 1.4.x version
  2. Open the app
  3. It appears to be really blurred with very low resolution (compare the status bar and the app to verify):

I followed the troubleshooting guide

Expected result

Obsidian matching the resolution of the screen and of all the other apps.

Actual result

The resolution of the app is extremely low, and it is way below the resolution of the display of my device.


Fedora Linux 38 (Workstation Edition)
GNOME 44.4
Linux 6.4.12-200.fc38.x86_64

The issue occurs with any packaging, including Appimage.

Additional information

  • Disabling Wayland and using X11 specifically for Obsidian solves the problem, even though the cursor appears as super tiny
  • Flatpak downstream bug report
  • This seems to be the problem, and it appears to be a Chromium/Electron problem. Could it be fixed upstream only, or something can be done specifically for Obsidian? :eyes:

Have you tried running with the --ozone-platform-hint=auto parameter ?

No… but I do not know how to add a parameter, if not via Flatseal… could you show me how?

You should be able to test with this:

flatpak run --env=OBSIDIAN_USE_WAYLAND=1 md.obsidian.Obsidian --ozone-platform-hint=auto

This fixed the issue for me completely. Could you please tell me how do I make this the default, so that whenever I launch Obsidian it launches with this parameter?

I have a test build that you can try, although I’m not sure whether to merge it since it didn’t appear to have helped @xplosionmind:

flatpak override --user --env=OBSIDIAN_USE_WAYLAND=1 md.obsidian.Obsidian

or, depending on how you’ve installed obsidian:

flatpak override --env=OBSIDIAN_USE_WAYLAND=1 md.obsidian.Obsidian

They also need to have--ozone-platform-hint=auto added, which is what the test build is for.

Hey, thanks to you all!

Unfortunately, the Obsidian resolution issue appears to be still happening with the command parameters you wrote in this thread.

The only solution still remains to fallback to X11.

the error you’re getting is because you’re passing --ozone-platfrom-hint to flatpak and not obsidian.
Regardless, --OBSIDIAN_USE_WAYLAND=1 is setting that variable (among others) for you as you can see in the first error message.

That error is what i made this post about.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.