Extra padding on embeded pages

Steps to reproduce

  1. Open the Help Vault.
  2. Navigate to the “Embed files” page.
  3. Observe that the “Accepted file formats” embed has extra padding at the bottom.

Expected result

The embed would render with a small amount of padding, perhaps 5px.

Actual result

The embed has about 130px of padding on the bottom. Curiously, it’s defined in the style of the element rather than the theme CSS.


I’m temporarily working around the issue by using the following CSS:

/* Remove extra vertical size from transclusions */
.markdown-preview-view .markdown-preview-sizer {
    /* I don't like using !important here, but a recent version of Obsidian
     * seems to have added a hard padding to the bottom of embedded
     * sections. */
    min-height: 0px !important;
    padding-bottom: 5px !important;


  • Operating system: Windows 10
  • Debug info:

Obsidian version: v0.13.25
Installer version: v0.12.19
Operating system: Windows 10 Pro 10.0.19044
Login status: logged in
Catalyst license: insider
Insider build toggle: on
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Safe mode: on


Additional information

will be fixed in 0.13.27

1 Like

Trying to solve this was driving me crazy, thanks so much for figuring it out! And props also to @WhiteNoise for incorporating the bug fix into the next update.


I was just about to report this issue with a new post + video, but found this post here.

Is this the same thing as I’m reporting here in this short video, and will be fixed in 0.13.27?

Short Loom video:


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.