Extra line-spacing when a generic list is created using a hyphen before or after a checklist

When a list is created using hyphens, before or after a list of checkboxes, there is extra line-spacing between the checkbox-list and the generic list. The same issue does not pop-up when an asterisk is used to create bulleted lists after or before a list of checkboxes.

Steps to reproduce

Create a list of checkboxes. Copy paste the below:

  • [ ] line 1
  • [ ] line 2
  • [ ] line 3

After this, create a list using hyphens using below:

  • Item 1
  • Item 2
  • Item 3

Now enter reading mode or export to PDF.

Expected result

Expect to see an evenly spaced list of bullets and checkboxes.

Actual result

Environment

  • Operating system: Widnows 11 latest public release as of today
  • Debug info:
    SYSTEM INFO:
    Obsidian version: v1.1.9
    Installer version: v0.15.8
    Operating system: Windows 10 Pro 10.0.22621
    Login status: logged in
    Catalyst license: none
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: light
    Community theme: none
    Snippets enabled: 0
    Restricted mode: off
    Plugins installed: 3
    Plugins enabled: 3
    1: Calendar v1.5.10
    2: Kanban v1.5.1
    3: Mind Map v1.1.0

In your screenshot the spacing between the 2 lists looks the same to me as the spacing within the list.

This is probably unrelated. Please download and reinstall Obsidian. Your installer version is out of date. It might not make a difference at all, but it might affect other things.

I can reproduce. I see the same behavior on iOS. In Reading Mode, there is more space between bullets. Even if there are blank lines between the checkbox list and regular list.

1 Like

The spacing is even. But the wider spacing only occurs (as far as I tested) if a bullet list follows a checklist.

If you put another block between them, the spacing expansion doesn’t happen.

1 Like

- [ ] test
- [ ] another
- [ ] again

seperator

- Test
- Test

seperator

- [ ] test
- [ ] another
- [ ] again

- Test
- Test

That source (except I changed the words “test” to “seperator” was what I showed in my screenshot on iOS in Reading Mode. I’ll test on computers tomorrow.

I am using a Windows 11 on Surface Pro. Haven’t tried it on another OS or device. I have tried a few trouble shooting steps, but the issue persists. Just thought of reporting as I know it is something that should ultimately be fixed in a product.

image

image

Yours looks good. Wonder what the difference in testing is; maybe comparing the debug info might help

Yeah I finally remembered to test on MacOS, and I don’t see the issue there.

I don’t have access to Windows for a while. But I guess this is OS dependent.

@rigmarole has shared the correct sample text using backticks, hence not duplicating it

This is not a bug but a feature! :slight_smile: It’s called loose list. I learned that recently.

1 Like

I think this is different from that.