External link does NOT open in READER view (but does in EDIT view)

Steps to reproduce

I’m trying to link to a file on my local hard drive, but outside of the vault.
The link is:


In EDIT view, when I click on it, the file opens.

In READER when I click on it, the file does NOT open.

Seems similar to How to change color for external-link in view-mode?
with the difference that the example there is an URL while I’ve linked to a local file OUTSIDE of the vault.

Did you follow the troubleshooting guide?


Expected result

that the file outside of the vault opens also when clicked in READER view

Actual result

In READER view when clicking on the link, nothing happens, the files doesn’t open.


Obsidian version: v1.5.2
Installer version: v1.4.13
Operating system: Windows 10 Enterprise 10.0.19042
Login status: logged in
Catalyst license: insider
Insider build toggle: on
Live preview: on
Base theme: adapt to system
Community theme: none
Snippets enabled: 0
Restricted mode: on


Additional information


Have you tried with [link](file:///C:\Users\Reif.Alexander\OneDrive%20-%20Ronal%20AG\ReifDrive\W16\5470\2023-12-05%2016_02_36-.png) ?

it works in the way you suggested Anwen

What I was doing wrong is omitting thefile:/// part before the path of the file

Issue solved.

Thank You Anwen.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.