External File Links Not Opening from Within a Table Cell

To illustrate this issue, I have a link to a simple text file that is located outside my Obsidian vault:


Link to a simple text file Clicking this link opens the file successfully - as shown in the captured sequence below. The makeup of this link is: [Link to a simple text file](C:/temp/TestFile.txt)

When the link is in a table, the link will not open the file even though hovering over the link shows that the location of the file is recognized by Obsidian. The makeup of the link is exactly the same as the link used outside of the table: [Link to a simple text file](C:/temp/TestFile.txt)

If the file is in the Obsidian vault. Then it opens just fine from a link within a table cell.

Please follow the bug report template when posting in this category.

It’s working for me with
[en](<file:///Users/USER/Desktop/hide tags.css>)

CleanShot 2023-07-26 at 14.25.56

Thank you so much for your response. I am sorry I did not follow the bug report template. This was my first time posting in this forum and I was not sure how to use the template correctly. Your example where you specified the syntax for identifying that this was a file that is external to the vault by using <file:///Users…> is what was the answer. As soon as I added this syntax all worked correctly: [label](<file:C:/temp/TestFile.txt>) then the file can be successfully opened from the link within a table cell. I wonder why this is only necessary for a link to an external file from within a table since the following link syntax works outside of a table: [label](<file:C:/temp/TestFile.txt>)

Thank you so much for your response as it solved the issue.



This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.