Exporting md to pdf produces no output

Steps to reproduce

  1. Select a markdown file
  2. Open Command Palette
  3. Enter “pdf” to locate the Export to PDF command. Click it.
  4. Select an output location (I’ve tried multiple). Save.

In my experience so far today there is no output file anywhere on the computer.

Expected result

A PDF file. This worked before; I use it somewhat regularly though it’s been a while.

Actual result

No file.


  • Operating system: Linux Ubuntu 22.04
  • Debug info: SYSTEM INFO:
    Obsidian version: v0.14.6
    Installer version: v0.12.15
    Operating system: #202204271406~1653440576~22.04~6277a18 SMP PREEMPT Wed May 25 01 5.17.5-76051705-generic
    Login status: not logged in
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: light
    Community theme: none
    Snippets enabled: 0
    Safe mode: on


Your installer is quite old.
You might want to update your installer.
Just download a new version from the website, no need to uninstall the old one.
(Installer updates are sometimes necessary to update some dependencies and are noted in the changelog)

Thank you for the quick response. Odd that the application updated at some point and left the installer stale. Just downloaded anew and installed. Perfect! Thank you!

That is normal, the installer is not automatically updated.
Doing fully automatic updates is hard in Obsidian’s case.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.