Exported PDF copies text in reverse

I’m not sure if this is a bug or a user error!

When I export PDFs from obsidian, if I try to then copy text from those PDFs, it pastes in reverse. Very strange. This also seems to render the PDF document un-searchable. If I want to find the location of the word “client” in a document, I am only able to get it to show up in search by typing “tneilc”.

I am not sure if this is the case for all themes or not, but definitely seems to be true of “obsidian_ia”, as well as a few others I have tried. PDFs exported from the default obsidian theme do not behave this way (they behave normally).

Any insight is appreciated!

sorry, we don’t take bug reports when thirdparty themes on plugins are involved.

alright, apologies & thank you!

I might re-post this in “help”, which I realize might have been the best place for it to begin with.

I just moved my workflow to Mac from Ubuntu and started having this problem. I export PDF, copy contents of Mac PDF Previewer into Mac Mail (or anything) and the contents are reversed.

I have:

  • Opened the same PDF with FireFox, and then cut and paste from there, and it works fine
  • Copied PDF to Ubuntu box, and copied from PDF viewer there into Evolution email and it worked fine.

Seems like the native PDF viewer on Mac is the culprit. Just following up here in case someone else stumbles across this problem.