Export to PDF: Stop native PDF viewer from opening

Whenever I use the “Export to PDF” option in Obsidian, it exports the file to PDF, but it also then tries to open my system PDF viewer (in this case, Adobe Acrobat) as soon as the export completes.

The trouble is, half of the time, I use Obsidian on a very slow and old laptop computer. The PDF viewer takes half a minute to start up every time it is opened, and is a significant use of system resources.

It is becoming very annoying to have to wait half a minute to close Adobe Acrobat every single time I export a PDF. Is there an option in the settings that I’m missing that will stop this behaviour “open after export?” If not, how else can I prevent this in a way that doesn’t impact my use of Adobe Acrobat outside of Obsidian? (e.g. changing the default PDF viewer isn’t viable)

This is becoming quite frustrating, and it appears there is no option in the settings to disable this. Is there another way that I am missing?

This has impacted me several times within the last few days, each time draining a substantial amount of my laptop’s battery. I am hoping someone knows how one would go about stopping this behaviour.

If not Obsidian, perhaps Adobe? Some ideas in this thread:

From the help thread you’ve linked, I’ve noted some key ideas from this specific post:

  • If the program converts to PDF by printing to the Adobe PDF printer, then Adobe Reader is the culprit for the file opening. The behaviour can be disabled through the Adobe PDF printer properties, as is shown in the reply you linked.
  • Otherwise, Adobe Reader is not the culprit for the file opening by itself. The behaviour must be disabled within whichever app downloaded the file. For example, in the post author’s specific case, they were saving the files to PDF using Microsoft Word. They disabled this functionality by unchecking a box labelled “Open file after publishing.”

I believe that in Obsidian’s case, it is the latter of these two possibilities, as I do not see signs that Obsidian is using the Adobe PDF printer, and also, turning off the Adobe PDF printer’s setting does not change the behaviour. This means that Obsidian is responsible for the file opening automatically, which means that the key to disabling this feature is somewhere within Obsidian.

Notably, as I have found from light experimentation, Obsidian runs on some form of Chromium browser, and my Chromium browser has a setting that can be switched off to stop PDFs from opening in the system viewer:

Perhaps there is a similar setting within the underlying Chromium browser Obsidian runs on that can be disabled.