Export files as text

Things I have tried

Installed Pandoc automatically from the web. Was able to export HTML files.

My Pandoc’s plug it says in red letters: Pandoc is not accessible or installed on you PATH. This plug-ins functionality will be limited. I saw no opportunity to do that.

I installed Pandoc, shut down Obsidian and opened it again. I was not able to use hot keys to export the current file as a text file.

I looked for a way to install Pandoc in my Obsidian vault, because I assumed that is the PATH of my files.

What I’m trying to do I am trying to export md Obsidian files as text.

My Pandoc’s plug it says in red letters: Pandoc is not accessible or installed on you PATH. This plug-ins functionality will be limited.

How do I install Pandoc on my PATH? What is my path?

Your files are text. You don’t need PanDoc for that.
You mean without markdown syntax?

Yes. There are three spaces between each line. It is messy for example to send an email using a boiler plate message that I have stored in Obsidian.

Is this all markdown? Installed theme or CSS? All syntax or some in particular?

When I cut and paste from Obsidian into email, I get single line from edit pane and as displayed from review pane. Single line gap between paras.

I assume you are having trouble with the Pandoc Plugin. Please see the developer’s web page, and this suggestion from that page:

A common issue is that the settings page will display the red error message Pandoc is not installed or accessible on your PATH. This plugin’s functionality will be limited.

If you encounter this issue:

Open the plugin settings and scroll to the bottom
There is a setting called Pandoc path. Set this setting to:
Mac/Linux: the output of which pandoc in a terminal
Windows: the output of Get-Command pandoc in PowerShell
After fixing it, relaunch Obsidian and it should (:crossed_fingers:) work!

@anon27868835 you seem to understand my problem.

I followed your instructions but something seems to be missing.

I pasted “which panda” in my terminal. I quit and started Obsidian. I started the export of text with a hotkey and got a message that the export took place. Then, I got a message that the file did not exist and so the export failed.

Here is what I copied into Obsidian from the Terminal.
image

My Obsidian files are in my iCloud so that I can sync my other devices and my Mac. Is that the source of the problem?

Hope you understand this set up better than me.

@Dor,
I have nothing requiring any coding. I just have ordinary markdown files.

You are right.

I just tried cutting and pasting from Obsidian and there were no extra spaces. Maybe my problem is solved.

It would be nice to get Pandoc working.

@Dor,
I have nothing requiring any coding. I just have ordinary markdown files.

You are right.

I just tried cutting and pasting from Obsidian and there were no extra spaces. Maybe my problem is solved.

It would be nice to get Pandoc working for other kinds of exports.

Ellen, I think you misunderstood the sequence needed to set this up.

  1. Open the Terminal
  2. At a prompt, in the Terminal, type which pandoc
  3. The Terminal should probably respond with /usr/local/bin/pandoc
  4. That is the location and path for the pandoc software. Copy the path. If yours is different than what I wrote in step #3, then use what you see in Terminal on your computer
  5. Open Obsidian and navigate to Settings and the Settings for the Pandoc Plugin
  6. Type the answer you see from step #2, above, that you see on your computer, into the Pandoc Path setting.

1 Like

I did this but it does not fix the problem.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.