Explorer shows less content (files ) on MAC than on the i.OS devices

I am having a similar problem.

I can see files in iCloud Drive via MAC explorer, but they are not showing up in my Obsidian explorer view or in search.

Also, Obsidian won’t load the Advanced Tables plugin

I upgraded to Ventura 13.1 last night, and both problems appeared this morning. I’m running Obsidian 1.1.9 (Installer 0.14.6)

That’s a very old installer

I downloaded Obsidian from the homepage, and my About Obsidian now shows Version 1.1.9 (Installer 1.1.9), but the files are still not showing up in the explorer.

Just for completeness, the problem here was that MacOS was managing my hard drive storage and offloaded those files to iCloud. I turned off “Optimized Storage,” and the files returned.

1 Like

Thanks CAWLIN for your answer.

  1. I am working with version 1.1.9 (installer 0.14.15).
  2. all files not shown in Obsidian Explorer on the Mac are located
    in the Finder in the iCloud/Obsidian directory.
  3. The synchronization is done via iCloud.

I still can’t explain this disfunction in Obsidian Explorer on the Mac.

Is there anything else that could be the reason for this lack of consistency in the
explorer display between mobil devices and Mac ?

Thanks a lot hoping for a solution.

Hi Brad,

Do I understand correctly that the problem is solved in your case ?
Was the key to the solution this statement " I turned off “Optimized Storage,” and the files returned."

What I don’t understand is where to find this “Optimized Storage” setting ?

Maybe you can give me a hint about this.

Many thanks for your understanding.

PS: I clicked the update button in the about settings and got the answer that my version 1.1.9 ( 0.14.15 ) is up to date. Therefore I do not understand how it happens with you to 1.1.9 ( Installer 1.1.9 )

Go to System Settings and type “optimiz” in the search box, and it should turn up.

I think their solution will probably work for you, too.

Do you mean the search box which is there because you’ve installed the Settings Search plugin?

Or are you somewhere entirely else? Like the system settings for the operating system?

The settings for the operating system.

Hi Cawlin,

Sorry, I searched and searched… to find the operating system. I definitely can’t find it anywhere.
Where is it hidden ?
Can you please help again ?

Thanks for understanding

Click the apple to the left of the Obsidian menu, then Settings (or Preferences if you’re on an earlier version of MacOS).

Hi Cawlin,
thank you for pointing this out again.
Unfortunately, there is no reaction, although I have selected the APPLE system setting.

What can still be faulty now ?
Can you please comment on this again.

Many thanks

PS. my Apple Version I am using is Mac OS Monterey v12.6

Your system language is german, so just search for “optimi” to see if something like “optimisierter Speicher” comes up.

1 Like

Go to System Preferences → Apple ID (at the top right) → iCloud (tab on the left) → Try to uncheck “Optimize Mac Storage”.


With a little bit of luck, follow this link and it’ll show up in german:

I hope that is the right section, could you verify that @CawlinTeffid , it’ll show up in english for you. Nifty feature of those mac guides, that it’ll show up in your local language.


That’s the one.

I have implemented all the suggestions. Nevertheless, everything has remained unchanged. I will now have to live with the limited solution.

Thanks for the support so far

I don’t know if it matters for this problem, but did you manage to update your installer? If not, the way to do it is to download the current installer from https://obsidian.md/ and install it.

I’m having the same issue. Mac Ventura 13.1. Obsidian 1.1.15. Ios devices showing the correct number of files (30,000) and Finder Get Info shows the same number. However Obsidian is showing 11,620.

Sync is done by Obsidian Sync and icloud and Dropbox are not involved. Icloud setting for Optimize Storage is off.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.