Exit Vim Mode

Things I have tried

I tried looking for a solution on the forum, google and obsidian help, however could not find anything.

What I’m trying to do

Steps to reproduce

Switch on Vim mode
Press esc
Enter ‘:q!’ or ‘:q’ or ‘q’

Expected result

Quit Vim mode

Actual result

Not an editor command “:q!”

How do get around this?
Macbook Air (Big Sur 11.5.1)

Go to the editor settings and toggle Vim keybindings off.


Thankyou for the reply. I do know how to exit vim from the menu. I meant to ask, is the “:q!” not supposed to work in obsidian. And if it is supposed to work, why isn’t it working in this case.

No, “:q” or “:quit” isn’t meant to work in Obsidian.

Are you just expecting that “:q” would turn off the keybindings? Or were you expecting it to do something different, like quit Obsidian, or close a note? Can you please explain?

Also please note that in Obsidian, you are not actually running Vim or using buffers. It’s a CodeMirror javascript library that only emulates a small subset of Vim. So any commands that would act on windows. or buffers or tabs or the program itself in Vim, will likely not work in Obsidian.

1 Like

Thankyou for the reply, I assumed “:q” would turn off the vim mode. I thought there’s a problem in my vault/software because of which this is not happening. Thankyou for explaining that there’s a difference between what is generally referred to as Vim and the Vim functionality in Obsidian. I just wanted to make sure that this isn’t a bug :smile:

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.