Existing files won't open

Not sure if I have been searching incorrectly but I cannot find help for this issue so far.

Every time I try to open an existing file, Obsidian doesn’t open it but instead opens a ‘No File’ window up instead. It also takes absolutely forever for it to load. Not sure what is wrong. It also creates like 10 of the same file and doesn’t let me open any??

I have my Obsidian files saved on my iCloud.

1 Like

This might possibly be an iCloud problem. But in order to tell you “what is wrong”, you should give us some more detailed information. How do you try to open the file? What is your obsidian version, including installer version? Could you deliver a screen recording of this happening? Are you using any plugins? etc…

2 Likes

Im having the same issue!
I disabled all plugins, even all the file related core plugins but it didn’t help.
obsidian version: v0.14.15

Before opening a file:

After clicking on a file in the file browser, or using the quick switcher:

Ive also tried to record profiler data but it doesn’t seem like its hanging. The capture resulted in the vast majority of the time being idle so its not like its loading for multiple seconds.

It happened on my work laptop so I have to be careful with sending logs and such but I hope that the screenshots help.

I fixed it!

Turns out obsidian really doesn’t like weird file formats.

I had a hand full of Alteryx files in my vault and moving them out of the vault solved the issue.

1 Like