Exclude Tag from Search

What I’m trying to do

I have my to do’s like this in Obsidian in my daily notes (I’m not using the To Do plugin or data view):
Do Laundry #Tasks/Chores

When it’s done, I mark it like that:
Do Laundry #Tasks/Archive

In the Obsidian settings under Files & Links there is an option to exclude files. I couldn’t make it exclude the Tag #Tasks/Archive from search though.

Is this possible at all? If not, are there any third party plugins / options to recommend?

Things I have tried

I searched the whole forum, tried different suggestions/regex code but couldn’t make it work. Sorry, if I have overseen something.

Thanks in advance for the help!

You exclude tags in the Search field by negating them with a hyphen, like this:

#tasks -#tasks/chores (searching this will find all #tasks including #tasks/archive but not #tasks/chores)

If you want to exclude notes with certain tags via the Settings window, I don’t think that’s possible.

1 Like

Thank you woofy, that helps!

There is no “shortcutting” for this though? I always need to manually enter this in the search bar to exclude?

1 Like

You should probably use tag:tag instead of searching for #tag. Using the tag field searches tags. Searching for the hashtag is a full text search.

tag:tasks -tag:tasks/Archive

Depends. Is this general searching? Or a specific search you perform often? You can bookmark a search.

Then you could use that bookmark to search. Or the community plugin QuickSwitcher++ has a bookmark mode, so you could access the bookmark from that launcher.

You could also embed a query in a dashboard note, so you can always see a live result of the search in a note.

tag:tasks -tag:tasks/Archive

That’s some very helpful tips here, thank you very much!

It’s actually just to prevent the Archive tasks to appear in any search as they clutter up some search results. So the ultimate goal would be to hide those tagged text lines in general.

If you have any more tips regarding that, I would be thankful, meanwhile, I’ll try out your tips!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.