Excalidraw - Full featured sketching plugin in Obsidian

Windows 10. Updated to latest version.
Obsidian 0.12.3 and previous
I have done the following:

  • It does not work from the icon in the left pane, nor when I use CTRL-P, create new.
  • It does work when I open an existing file.
  • I have deactivated all plugins and CSS
  • I have created another vault and it does work when I create a new graphic.
1 Like

Hi Julian, I am sorry to hear that. It works for me… I also have the latest version and also 0.12.3. I’ve tried it on Windows 10, Android and chromeOS as well. All works well for me.

Can you open console log (CTRL+Shift+i) and see if you can see any errors.

Please create an issue on github with as much detail, maybe also screenshots as possible.

Issues · zsviczian/obsidian-excalidraw-plugin (github.com)

You can manually downgrade to 1.0.9 by copying main.js, manifest.json and styles.css to your .obsidian/plugins/obsidian-excalidraw-plugin folder from here:
Release Excalidraw 1.0.9 · zsviczian/obsidian-excalidraw-plugin (github.com)
You need to restart Obsidian after you have copied the files to the folder.

Please let me know if this solves your issue.

The solution I did was to create another vault with my data and it worked again. Thank you.

Thanks for letting me know! I am happy you could get it working again!

1 Like


integration of PKM with e-ink tablets like reMarkable or Onyx BOOX would be game-changing!

haven’t seen much crosstalk btw these two types of communities yet, but expect it to come.


@zsviczian Your plugin changed with Obsidian the way I think!

The last version makes it much more well-rounded. Thank you so much

1 Like

@zsviczian - thank you so much for your excellent plugin!

I use my vault inside a virtual machine without internet access, before this latest update I only have trouble with loading pre-downloaded libraries into your plugin - but now the plugin does not load at all…

I am using the Obsidian Linux AppImage 12.10 and Excalidraw 1.2.8 plugin in Debian, this is the Dev Console output with all other plugins and css disabled;

Is it possible to continue using your plugin without network connection?

It would be great if the live collaboration feature would also work in Obsidian.


Hi, I am using excalidraw 1.2.9 on ipad with obsidian 1.0.3 and if you try to draw a small circle or write its not very precise. You must draw very slowly some elements: circle, write… If you write a square is enough fast and you dont notice any delay.

Its like the sampling needs more cpu or takes too much resources to catch the ipad pencil movements.

So, I have to sketch two speeds under my normal.

Excalidraw project is exciting because Obsidian needs a tool to sketch. Take notes is much more than writing, its also sketching


I was using Mermaid in Obsidian and it’s quite convenient to draw a flowchart since you don’t have to worry about the position and the size of any squares, elliptic or triangles, etc.
Excalidraw elevates drawing and note organization to another level. The elements in the drawing could actually link to notes and texts in the obsidian vault, which Mermaid could not possibly realize.
So, I wonder if you could combine mermaid with Excalidraw or add Mermaid like graph making syntax to Excalidraw to combine the intuition of Excalidraw and the convinience of Mermaid

I found mermaid could link to files by the following syntax:

graph LR
A[Note Name] --> B 

class A internal-link;

this is where I found it Hassle free linking in mermaid graphs - #9 by WhiteNoise

Amazing plugin !!!
One question: is it possible to copy paste some native content from one file to another ?

Do you mean to copy objects from one drawing to another? That should work. Did you try CTRL+C in one drawing then moving to the other and pressing CTRL+V?

@zsviczian - could you check this issue please, I made a Microsoft account and posted this issue to Github a month ago but it never showed up.

I am uncertain what the problem may be. I just tried going offline with my PC and starting Obsidian with Excalidraw. It all worked without any issues.

The first error - if thrown by Excalidarw - seem to suggest that the drawing you are trying to open is corrupted. I am happy to take a look at the file if you send it to me. However, that should not result in Excalidraw not working at all.

You may also try deleting the Excalidraw plugin’s data.json, maybe that will help. This will delete all your Excalidraw settings and your stencil library in Excalidraw. (you can also simply rename the file to data.json.old, then start Obsidian)

Yes it works if you have previously opened your vault with network connected. But if you create a new vault offline and manually install the plugin, it does not load properly. There are no commands in the Palette and no icon in toolbar, yet Excalidraw menu appears in Community Plugins.

I have just tested with Obsidian Help and get same result. This is just Obsidian loading, no attempt to open drawing.

What are these remote javascript attempting to load from unpkg.com?

Gone back to version 1.1.10, at least it works without requiring remote javascript execution.

Thank you again for raising it. With some help on OMG I found a solution. Please try version 1.3.1 and confirm if the downloading is resolved. Everything should now be packed in the main.js of the plugin. :crossed_fingers:

Ah thank you so much @zsviczian, it works fine now. I can also import downloaded stencil libraries, this was never working before.

I was afraid I would miss out to work with your Clothesline concept!

1 Like