Everytime I use Obsidian, the note disappears

Note Disappears Mid-sentence.

I recently started using obsidian to take notes on my classes, and I appreciate the efficiency and convenience of having designated vault for my notes. What I don’t appreciate is that, without fail, any time I’m writing a new note (at random moments) the note will disappear mid-sentence. When I search for it, it’s not there, and the only way I can manage to retrieve it is to either copy a snapshot, or quit and reopen the app. Apparently the note is still there -as shown by the fact it reappears when I restart the app- but this entire process is too tedious to go through every time I need to jot something down.

I already went through the effort of familiarizing myself with Obsidian and am not really up for the idea of migrating to another note-taking site, so I was hoping someone has any ideas/solutions for my problem (I’ve checked similar posts on here, but they were either a different issue or the solutions were insufficient). Thanks for taking the time to read this and I hope this can be solved!

(Also worth noting is I have zero community plugins which could potentially cause issues.)

Can you post your debug info? Use the “Show debug info” command, and paste the info here :slight_smile:

Here it is:
SYSTEM INFO:
Obsidian version: v1.6.3
Installer version: v1.5.12
Operating system: Darwin Kernel Version 20.6.0: Thu Jul 6 22:12:47 PDT 2023; root:xnu-7195.141.49.702.12~1/RELEASE_X86_64 20.6.0
Login status: not logged in
Insider build toggle: off
Live preview: on
Base theme: adapt to system
Community theme: none
Snippets enabled: 2
Restricted mode: off
Plugins installed: 0
Plugins enabled: 0

RECOMMENDATIONS:
Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.

Also, where is your vault saved on disk?

This can happen if the vault in a sync service (OneDrive, iCloud Drive, Google Drive, etc.) location or a folder watched by that sync service (often Desktop and Documents). If the files and folders aren’t set to always be local, the service may evict them from the device up to the cloud.

I did sync my vault directly to Google Drive as I saw a video on Obsidian which recommended that, so you may be right. I changed my Drive settings to “Mirror Files,” would that be the correct option to stem this problem?

I haven’t used GDrive in a while, but I believe that’s correct. I think they call the options “mirroring” and “streaming”? You want the “mirror files”.

Let’s hope that’s the cause. :crossed_fingers:

1 Like

Thanks for the help! I’ll check for any issues and give an update in a few hours.

I managed to finish an entire note without it peacing out on me mid-sentence, thanks for the help guys!