Everything is gone after updating to 1.4.14

First at all, I just updated to Sonoma on my Mac. Everything worked fine except Obsidian. I’ve all my notes in iCloud.
After a few hours waiting and restarting, it worked but requested that the next update needs to download the file and run it: Obsidian-1.4.14-universal.dmg
When I clicked it said it needs to replace the old application, I accepted and now I have all my notes but all my configuration and plugins are gone. Please help

Could be iCloud hasn’t redownloaded everything?

1 Like

Actually I don’t think that iCloud needed to download anything.

I checked the Icloud Drive and I never saw the updating icon moving. It was a OS update, so I don’t think it needed to delete/download files so I don’t understand why Obsidian has issues at the beginning.

From what you’ve said so far, it doesn’t sound like there is any issue in Obsidian. The Obsidian installer will not have removed your vault settings. Obsidian can only work with the files on your computer. If iCloud didn’t download your hidden .obsidian folder, that is an iCloud issue.

You can view hidden folders in MacOS by hitting Cmd-Shift-. (period)

If you show those hidden folders, it’s possible that you’ll see where iCloud hasn’t downloaded something yet. Maybe not. Maybe it’s something different.

But… if that folder was missing, and you opened Obsidian, there is a chance Obsidian made a fresh default .obsidian folder. So you might have to go into your iCloud account to see if you can restore an older version. (I don’t know if that is possible or not.)

(Syncing tools like iCloud aren’t sufficient for keeping safe backups. I recommend you routinely backup your vault and important data occasionally.)

1 Like

Thanks for your answer too.

My .obsidian folder is in the place and full of files. Is anyway I can re-open my vault to get that loaded?

As I said, if you had been missing that folder after updating MacOS, Obsidian would have created a new default one for you. Is the .obsidian folder full of your old plugin settings?

If no, then you might have to find a way to restore the old version from iCloud.

I don’t understand the question. Are you having a problem opening your vault?

Or do you see all your plugins in the .obsidian folder, but they don’t load in Obsidian? Can you please be more specific about what you are seeing right now? Maybe some screenshots would help.

1 Like

I sorted the files per Date Modified

All the folders are showing my old stuff. I don’t understand why obsidian is missing the folder.

This is obsidian with another theme as usual as showing that the plugin is not active:

The “missed” plugin is here:

I would copy your whole vault over to a different place on your drive and open that copy and see if it works. Also right click on the header to turn on the iCloud Status column and make sure its all downloaded. If you copy it it will force a download anyhow but I’d stop messing with the iCloud copy and get a fully local copy working first.

Then I’d go into settings and see if the plugin is installed. If its not its likely missing from the community plugins JSON file. “All the folders are showing my old stuff. I don’t understand why obsidian is missing the folder.”. If some plugins are loading and some aren’t likely you’re going to find them missing from that JSON file.

Agreed - it could just be the screenshot - but everything looks greyed out which could mean it’s not downloaded from iCloud.

Thank you !!, I just closed Obsidian, zipped and renamed the folder, opened back Obsidian, select the new folder and everything is working like usual.

Things were greyed out because they were hidden folders. I was sure everything always was there.

I’m still not understanding what happened but I’m happy it’s working back.

I expect what happened was everything just wasn’t downloaded. Zipping it would have forced a complete download of everything.

Honestly if you’re a heavy user of iCloud Drive turn on that status column in Finder.

Also the thing to remember is that iCloud will remove stuff to make space so if a file isn’t updated in a long time (likely for some of the stuff in the .obsidian folder that wouldn’t get updated often) it might get moved out if space is required. Its one of the reasons I decided to just pay for Sync again which doesn’t have that problem (not to mention file versioning, etc).

1 Like

Everything is still greyed out and working well.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.