Escaped characters should have the normal text color in Live Preview

Steps to reproduce

In Live Preview, type escaped characters like \$ (very useful for entering dollar amounts) or \* (useful for entering some quick math formulas).

Expected result

When escaped, characters are meant to be normal text and should thus have the same color as normal text.

Actual result

Escaped characters appear in the same color as their non-escaped version ($ for a math formula, * for italics or bold, etc.). This is unexpected, as they are normal text. Also, and more importantly, it can make such characters harder to read (especially in some dark modes, for instance in the Things theme).

Environment

  • Operating system: macOS Ventura.
  • Debug info:
    SYSTEM INFO:
    Obsidian version: v1.0.3
    Installer version: v0.15.8
    Operating system: Darwin Kernel Version 22.1.0: Sun Oct 9 20:14:30 PDT 2022; root:xnu-8792.41.9~2/RELEASE_ARM64_T8103 22.1.0
    Login status: not logged in
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: adapt to system
    Community theme: Things
    Snippets enabled: 1
    Restricted mode: off
    Plugins installed: 8
    Plugins enabled: 4
    1: Style Settings v0.4.12
    2: Outliner v4.1.1
    3: Remember cursor position v1.0.7
    4: Linter v1.7.0

1 Like

thanks