Error in 1.6.1 frontmatter editor

Error in the frontmatter editor that is causing a loss in functionality.

How to reproduce:

  1. created a new note
  2. type in “—” to add frontmatter
  3. type in “cssclasses”, instead of “cssclass”
  4. Saw my error and tried to fix it, by changing it to “cssclass”
  5. Edit will not allow the change, and undoes the change, reverting it back to “cssclasses”
  6. I tried:
    6a. changing it to “cssclass”
    6b. adding [space] to ending, i.e. "cssclass "
    6c. closing the app and reopening, then 6a and 6b
    6d. tried editing the file on disk, but when I went back to the editor, the change is reverted.

I can now not set the cssclass on any note. This breaks many of my use cases.
It also is a problem not just for this case, but many use cases where a typo once typed
can affect all notes edited in the editor app.

cssclass is depreciated.


cssclasses is correct and cssclass will be reformatted to cssclasses if you use the Properties in document in any way.

Even if you type cssclass in Source mode, it will still be displayed as cssclasses in Live Preview and Reading Mode.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.