Error EPERM : Operation not permitted : can't delete any plugin

I have an internal SSD named K:/ that contains my Obsidian Vault. I can’t succeed to delete any plugin and have an error log :

Uncaught (in promise) Error: EPERM: operation not permitted, rmdir 'K:\PARA\.obsidian\plugins\obsidian42-strange-new-worlds'

(Strange New worlds is an example)

Or, for another plugin :

app.js:1 Uncaught (in promise) Error: EPERM: operation not permitted, rmdir 'K:\Nest\.obsidian\plugins\omnisearch'

Steps to reproduce

  1. Set an internal SSD
  2. Create a new vault in it
  3. Download a new plugin
  4. Try to delete this plugin.

Expected result

Successfully deleted plugins

Actual result

Error and the modal for deletion not disappear.


  • Operating system: Windows 11
  • Debug info:
	Obsidian version: v1.0.3
	Installer version: v0.14.15
	Operating system: Windows 10 Education 10.0.22623
	Login status: logged in
	Catalyst license: insider
	Insider build toggle: on
	Live preview: on
	Legacy editor: off
	Base theme: light
	Community theme: AnuPpuccin
	Snippets enabled: 44
	Restricted mode: off
	Plugins installed: 89
	Plugins enabled: 80
		1: Dataview v0.5.47
		2: DB Folder v2.7.4
		3: AidenLx's Folder Note v0.16.4
		4: Banners v1.3.3
		5: CodeMirror Options v0.9.5
		6: Commander v0.3.0
		7: Customizable Menu v2.2.0
		8: Editing Toolbar v2.2.0
		9: File Info Panel v1.2.5
		10: Folder Note Core v1.3.5
		11: Hider v1.2.3
		12: Homepage v2.4.1
		13: Icon Folder v1.3.5
		14: Icon Shortcodes v0.9.7
		15: Markdown Table Editor v0.3.1
		16: Minimal Theme Settings v6.1.0
		17: Style Settings v0.4.12
		18: Window Collapse v1.0.2
		19: Bartender v0.5.7
		20: Default New Tab Page v0.10.0
		21: Theme Design Utilities v0.20.1
		22: Auto Card Link v1.1.1
		23: Better Word Count v0.8.1
		24: Editor Syntax Highlight v0.1.3
		25: Copy Image and URL context menu v1.4.0
		26: Hotkey Helper v0.3.15
		27: Markdown Attributes v1.2.2
		28: MetaEdit v1.7.2
		29: MySnippets v1.2.3
		30: No dupe leaves v0.0.5
		31: Table Enhancer v0.2.2
		32: Another Quick Switcher v7.2.1
		33: Auto Link Title v1.2.5
		34: Contextual Typography v2.2.4
		35: Dynamic Highlights v0.3.1
		36: Folder Focus Mode v0.9.8
		37: Group Snippets v1.8.3-0
		38: Hover Editor v0.11.6
		39: Image Toolkit v1.3.1
		40: Metacopy v1.5.0
		41: Github Publisher v4.5.0-2
		42: Paste image rename v1.5.0
		43: QuickShare v1.0.1
		44: Snippet Downloader v2.0.1
		45: Sortable v0.2.6
		46: Table Generator v1.3.1
		47: Trim Whitespace v0.2.2
		48: Settings Search v1.2.0
		49: Simple Embeds v1.13.0
		50: Supercharged Links v0.9.3
		51: Waypoint v1.3.0
		52: Obsidian Editing Toolbar v2.1.5
		53: Literate Styles v0.2.0
		54: Projects v0.20.5
		55: AidenLx's Folder Note - folderv component v1.0.0
		56: Better footnote v1.0.1
		57: Copy as HTML v1.0.5
		58: Format Hotkeys v0.1.7
		59: Link Favicons v1.8.1
		60: Natural Language Dates v0.6.1
		61: Admonition v9.0.5
		62: CM6 Attributees v0.0.5
		63: Footnote Shortcut v0.0.9
		64: Front Matter Title v2.5.0
		65: LanguageTool Integration v0.3.0
		66: List Callouts v1.0.9
		67: Local File Interface v0.1.0
		68: Meta Bind Plugin v0.3.0
		69: Smarter Markdown Hotkeys v1.16.2
		70: Tidy Footnotes v0.1.1
		71: Wrap with shortcuts v1.2.0
		72: Clear Unused Images v1.0.6
		73: PARA Shortcuts v1.0.5
		74: QuickAdd v0.5.5
		75: Advanced Tables v0.17.3
		76: Templater v1.15.2
		77: Kanban v1.5.1
		78: Linter v1.7.0
		79: Obsidian42 - BRAT v0.6.36
		80: Metadata Menu v0.3.2

	Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
	Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

  1. I tryed another Vault in the same SSD : No problem.
  2. With Sync, I can successfully delete any plugin, on my iphone or Ipad.

I tryed multiple time to recreate the vault, with moving, create from syncing… No success : after some days, I can’t delete any plugin.

I spotted that the plugin disappear from the list after trying to delete it, but the folder was keep in the folder .obsidian.

This seems a filesystem level permission problem, can you cancel those files from file explorer?

Also, download and reinstall Obsidian.

Yeah, I can delete them using the Fire Explorer without problem.
Will try with reinstallation.

No change with reinstalling Obsidian.
The error appear also for deleting themes : Uncaught (in promise) Error: EPERM: operation not permitted, rmdir 'K:\Constellation\.obsidian\themes\Willemstad'

I think you have permission problem at OS level, you need to check your files and directories in your OS.

I agree that this is a File System error, but it is not a permissions issue… or at least for me, it’s not. The one thing that @Mara-Li and I have in common is that both of our vaults are in a file sync’d folder. In my case, it’s Google Drive.

What I observed was that when I uninstalled a plugin (in this case it was Kanban)

  • The uninstall button doesn’t change and the dialog remains active
  • The Obsidian Developer Console shows the error Uncaught (in promise) Error: EPERM: operation not permitted, rmdir F:\CloadFiles\Google\Home\Docs\ObsidianVaults\Sandbox\.obsidian\plugins\obsidian-kanban
  • Re-clicking on uninstall has the same results as the prior two bullets
  • Wait 2 - 5 minutes
  • Restart Obsidian and open the same vault
  • Plugin is no longer in Community Plugins

I speculate that the uninstall did what it was supposed to do up to the point where it tried to remove the folder for the plugin. At this point, “Google Drive” wakes up and starts synchronizing the delete and has a lock on the plugin folder, therefore the rmdir from Obsidian fails. The pause and restart of Obsidian gives Google Drive enough time to finish synchronizing the delete.

I was able to capture this with a log from ProcMon from sysinternals. I had my filter set to “Path” “contains” “kanban”.

For me, I think I’m going to move my vaults out of “Google Drive”. I really don’t use vaults on other devices as much as I thought I would.

Hope this helps,

Edit: noticed a typo

1 Like

Problem : I don’t save my Obsidian folder, I only use sync.

The only folder with a Google save is my icons folder, a secret folder, because it is not sync (.icons)

So I don’t think it’s link to Google drive. I also tryed to remove GD and the issue remains.

Does this happen in a vault somewhere else in your os?

The strange things is : no
More : It doesn’t appear on any vault, any place.
On this specific vault, moved elsewhere, bug too.

you need to look at the files permissions

I also tried to recreate the vault from Sync and I have also the problem.

Also, I noticed other stranges things : some plugin are deleted without error, other not.

For example, I successfully removed Mini Toolbar or Boost Link Suggestion, but Hot reload or Obsidian Dev Tools struggle to be deleted (these plugin wasn’t loaded when I tried to removed it).