Error code seemingly deleting entire vault

Opened it up today and received error code ENOENT: no such file exists, and it deleted several notes. Upon closing and reopening the app, the entire vault shows error message: No such vault exists and I can’t access anything. please Help.

Update: I can still find the vault in my files, but it won’t let me open it through obsidian anymore. Accessing it from my phone results in the sync deleting files one by one in front of me, Same issue. All my vaults show the message: Unable to open, file not found. Upon closing and opening obsidian again, it guides me to the open new vault, and claims that there are no vaults on the computer. Upon opening my previous sync, All those files in one folder are gone.

The files no longer exist in the restore files tab. And they don’t exist on my saved vault on my computer.

What I’m trying to do

Access my work like normal

Things I have tried

Other pages say they had the same issue, and it was a community plugin, but I have community plugins disabled and have never turned them on.

Where do you store your vault? In some of the other similar threads, I think it was about some kind of network drive tool.

What OS? What version of Obsidian? (Plus what installer version?) (You can also just paste the results of “Show Debug Info”.)

How are you syncing? Obsidian Sync?

Anything else you can think of?

My notes aren’t even linked together, they’re just notes in folders, so pretty basic. I had I think about 13-14 notes deleted, maybe a few smaller ones. They were each about 5-10k words each.

the most recent version of macOS and obsidian I believe. Where would I find show debug info?

And yes, Obsidian sync. Is there a way to just restore everything back to a previous backup?

That’s not relevant to this issue. Where are you storing your vault? (NAS, network folder, sync tool?) That is a more likely issue.

In Obsidian: Cmd-P for the command palette. “Show Debug Info”.

There are some ways to restore your notes. But for a full backup of your entire vault, you likely need to use your own backups. BUT, you should really solve what is causing issue, otherwise it might just keep happening.

Im not sure to be honest, I could find the folder in my Finder files on my Mac, so there? When it first happened, I could find all of the deleted notes there, but the next time I checked, they were also deleted. I usually rely on the obsidian sync and write from multiple devices, 3 different apple devices, and one windows device much more infrequently. (not within the last month)

Obsidian version: v1.3.7
Installer version: v1.2.7
Operating system: Darwin Kernel Version 22.5.0: Thu Jun 8 22:22:22 PDT 2023; root:xnu-8796.121.3~7/RELEASE_X86_64 22.5.0
Login status: logged in
Catalyst license: none
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: on


What folder? Can you share the path here? (Hide your username if you want.)

And I’d suggest sharing the path on both the Mac and Windows. Are the files gone on all your computers/devices?

I’m trying to figure out if you are storing it either:
a) Somewhere where either MacOS is syncing with iCloud, or Microsoft is syncing with OneDrive. If you are storing in some default OS folder, then this is possible. Then that means you are using two sync tools at once, and this can cause bad issues.
b) Some kind of cloud/network folder. Like Dropbox, Google Drive, or a network-attached-storage (NAS).

I cloud drive > Documents > Documents (x MacBook Pro) > Writing2

I don’t have access to my windows device right now. I do have the issue on my phone, which is the other device it is synced to. how would I disable the folder being synced under iCloud? I also have not changed any other settings recently on my computer, so why would the issue occur now? if I can disable the sync of this specific folder, would I be able to restore my previous documents if that is the issue?
Sorry for all the questions.

You would choose a vault location that isn’t inside iCloud.

Who can say! You’re mixing syncing tools, so occasionally they will race each other. Or iCloud sometimes “optimizes storage”, and moves things to online-only. But if that happens, Obsidian Sync would think the files were deleted, and that would be synced across your devices.

I can’t really help you much. But here are some things you should probably do:

Step 0: If your notes are still on any device, back them up immediately. Make a copy or a zip file and save it somewhere for now.

  1. Turn off “Optimize storage” in MacOS, so iCloud won’t automatically offload your files. System Preferences → Apple ID → iCloud → uncheck “Optimize Mac Storage”.
  2. Try to restore your files using the features in Obsidian Sync.
  3. If that fails, maybe iCloud is storing a backup online somewhere. I have no idea.
  4. If you can get your files back, you must move your files out of iCloud and/or OneDrive and any other cloud/sync tools, if you intend to continue to use Obsidian Sync. There is a “Move Vault…” feature in the vault switcher inside the app.
  5. Keep good backups in the future. (General advice for everyone.)
1 Like

where could I find the features to restore my files on Obsidian?

I turned off iCloud syncing for Obsidian, and moved it to somewhere that I believe will not attempt to sync with iCloud.

I restored them using the bulk restore feature, but the file that I blacklisted from I cloud sync still doesn’t contain them, and its giving the same message. How would I get them back for Obsidian to recognize them?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.