EPERM Error: damaged file

What I’m trying to do

When opening the vault, I get the error: EPERM: operation not permitted. Istat “pathfile.md”

Things I have tried

checked the file permissions - the file has no owner, can’t set them new
tried to delete the file - can’t be deleted
reboot - didn’t help

How am I able skip this file to start the Vault?

The error might be caused by a different program but i need to access the vault asap.


What OS are you using?

Can you say what different program may have caused the error?

You tried deleting the file how? Depending on your OS, there might be other ways to delete it, like from a terminal or cmds.

And if you delete it rather than somehow fix permissions, are you losing any valuable information?

Also you can find some previous discussions about this. Search results for 'eperm' - Obsidian Forum

1 Like

I’m using Windows 11 Pro, syncing with Onedrive and encrypting with Cryptomator.

When deleting, it disappears but seems to stay. Can’t create a new file with the same name to replace the damaged one, as the name is already used. Therefor the error is persistent too, after reboot the file shows up again.
I tried do copy the file as backup to a different directory but then I get an error “Path doesn’t exist”.
During the last troubleshooting I had an error too, which displayed the file is to big for the filesystem… Tried to disable Onedrive, checked the file on an other synced pc, no luck.

Now while trying to document the behaviour i first opened the file with VSCode, it showed an empty file. The opened it with Notepad++ and received the message, file doesn’t exist - do you want to create it?

I did, the file was saved and Obsidian is able to start again. Lost the file content but that’s ok in this case…

Thanks and regards

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.