Enter key doesn't work

Since restarting my computer, in edit mode, when I press the enter key (on a Windows 10 Dell laptop), nothing happens. Previously the enter key created a new line as expected. However if I press shift + enter then a new line is created. The enter key works as expected in my other programs (Notepad, Word, Chrome etc.)

Do you have any plugins enabled? Does it show this behavior in the Help vault?

Did you enable vim mode? Is the cursor green?

Although this is now a non issue for me, hopefully this helps. I temporarily had this exact same issue last night using 0.12.3. This was a day after I had installed then uninstalled Dataview, Templater, Outliner, and Sliding panes on this particular vault.

Also, not sure if it is related, but it happened right after I set the hotkey for toggle heading to Alt H on Windows 10. I am not sure what Toggle Heading is supposed to do, but Obsidian wasn’t responding to that hotkey either. After a little while Enter would work again then stop.

I had no plugins or custom css on the vault. I uninstalled then reinstalled Obsidian and the Enter problem went a way. I will do more testing when I get on computer later today and look into the Toggle Heading thing.

Thanks.

It does not display this behaviour in the help vault. I have no community plugins installed. I have some custom CSS. I do not have Vim Key Bindings enabled.

Problem is now solved. I simply closed and reopened Obsidian. Sorry a simple thing I should have tried :sweat_smile: Although a strange behaviour nonetheless

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.