ENOSPC: no space left on device

I was editing a note and I ran in to a problem I don’t know exactly what happend. Can anyone help me solve this issue? I can’t save or edit any new file. Thanks in advance.

Error: ENOSPC: no space left on device, open ‘/home/ehudd/Google Drive/Brain 1.0/Applied Linux Command Line and Shell Scripting Zero to Elite.md’

Here is some info about my system.

inxi -F
  Host: endeavour Kernel: 5.14.14-arch1-1 x86_64 bits: 64
  Desktop: KDE Plasma 5.23.1 Distro: EndeavourOS
  Type: Laptop System: TOSHIBA product: Satellite U940 v: PSU6SP-01CLM1
  serial: <superuser required>
  Mobo: TOSHIBA model: VCUAA v: 1.00 serial: <superuser required>
  UEFI: TOSHIBA v: 1.20 date: 09/19/2012
  ID-1: BAT1 charge: 10.6 Wh (100.0%) condition: 10.6/32.6 Wh (32.6%)
  Info: Dual Core model: Intel Core i5-3317U bits: 64 type: MT MCP cache:
  L2: 3 MiB
  Speed: 911 MHz min/max: 800/2600 MHz Core speeds (MHz): 1: 911 2: 822
  3: 836 4: 1019
  Device-1: Intel 3rd Gen Core processor Graphics driver: i915 v: kernel
  Device-2: Chicony TOSHIBA Web Camera - HD type: USB driver: uvcvideo
  Display: x11 server: X.org 1.20.13 driver: loaded: intel
  unloaded: fbdev,modesetting,vesa resolution: <missing: xdpyinfo>
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: Intel 7 Series/C216 Family High Definition Audio
  driver: snd_hda_intel
  Sound Server-1: ALSA v: k5.14.14-arch1-1 running: yes
  Sound Server-2: PulseAudio v: 15.0 running: yes
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet driver: N/A
  Device-2: Intel Centrino Wireless-N 2200 driver: iwlwifi
  IF: wlan0 state: up mac: 9c:4e:36:81:87:cc
  Device-1: Integrated System Solution Bluetooth Device type: USB
  driver: btusb
  Report: rfkill ID: hci0 state: up address: see --recommends
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci
  Local Storage: total: 495.58 GiB used: 223.01 GiB (45.0%)
  ID-1: /dev/sda vendor: Toshiba model: MQ01ABF050 size: 465.76 GiB
  ID-2: /dev/sdb vendor: Samsung model: MZMPC032HBCD-00000 size: 29.82 GiB
  ID-1: / size: 28.68 GiB used: 15.9 GiB (55.4%) fs: ext4 dev: /dev/sdb2
  ID-2: /boot/efi size: 511 MiB used: 296 KiB (0.1%) fs: vfat dev: /dev/sdb1
  Alert: No swap data was found.
  System Temperatures: cpu: 51.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 236 Uptime: 8h 3m Memory: 7.66 GiB used: 2.35 GiB (30.7%)
  Shell: fish inxi: 3.3.07

As the message suggests, do you have any space left on your hard drive?

Yes I have enough space in my HDD. It seems like is blocked to Obsidian. I found a way to solve this issue moving the Google Drive folder to an other partition but the old directory still presentting that error.

Did you try the solution here?

I tried to solve the problem with the info in the post but unfortunately it didn’t work.

In the latest update to Google Drive, I notice it now appears as a separate mounted volume in MacOS. Maybe it is the same in Linux. Did you run out of space in your Google Drive?

Yes, I noticed the same thing in Windows now they appear as separate volumes, however, it shouldn’t be a problem because my google drive account has about 8GB of free space.

I think it’s a physical problem with my hard drive because when I changed the location of my VAULT to an SSD the problem disappeared, I can’t think of anything else why it’s not working and showing me this error.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.