Emojis no longer show up in Edit Mode

Hello everyone!

Since today I have the problem that emojis no longer show up in Edit Mode. Instead, there’s a blank space.

I’ve tried:

  • Reload without saving
  • Closing an opening Obsidian
  • Restarting my computer
  • Changing Themes from AnuPpuccin to Default

But nothing worked. Does anyone know how to fix this? :frowning:

1 Like

Disable the Iconize plugin and reload/restart Obsidian?

1 Like

That helped, thank you!

Hello, I also have this same issue. Whenever I have Iconize enabled, the emojis disappear, but the FontAwesome icons are rendered. When Iconize is disabled, the emojis go back in view, but the FontAwesome icons aren’t rendered and are just plain text.

I tried doing the Disable Iconize > close Obsidian and open again and tried turning on Restricted mode and restart Obsidian to see if anything else happens but nothing changes. Am I missing something? D:

To add: this seems to only happen in Live Preview. If in Source or Reading mode, the emojis appear :sweat_smile:

Iconize seems to have worked out their kinks, so a recent version shouldn’t experience these kind of issues.

Seems like Iconize still causing emojis not showing up, even after update.

My issue is that it means I have to choose between Iconize and the Tasks plugin.

The issue is currently discussed.

A solution is to disable “Toggle icons while editing notes” in Iconize settings. This means you can’t use Iconize in notes, but still can assign to files and folders.

I was having the same problem. It seems the latest Iconize update solves this problem. I updated the plugin and restarted, and it works.