Emoji in headings aren't displayed in PDF exports

The issue:

Emoji in headings aren’t displayed/included in PDF exports.

Steps to reproduce

  1. Paste this into the Sandbox vault:
# whoa πŸ˜†πŸ€¨πŸ˜πŸ₯³πŸ˜±πŸ«¨

## πŸ©΄πŸ‘˜πŸ‘ πŸ§€β›‘οΈ

πŸΈπŸ¦πŸ»β€β„οΈπŸ±πŸŸ

  1. Export PDF

Did you follow the troubleshooting guide? Yes

Expected result

Emoji is displayed in the PDF.

Actual result

Emoji in headings are missing on PDF export.

Environment

macOS Ventura 13.6 (22G120)

SYSTEM INFO:
	Obsidian version: v1.4.14
	Installer version: v1.4.14
	Operating system: Darwin Kernel Version 22.6.0: Fri Sep 15 13:41:28 PDT 2023; root:xnu-8796.141.3.700.8~1/RELEASE_ARM64_T6000 22.6.0
	Login status: logged in
	Catalyst license: supporter
	Insider build toggle: on
	Live preview: on
	Legacy editor: off
	Base theme: dark
	Community theme: none
	Snippets enabled: 0
	Restricted mode: off
	Plugins installed: 0
	Plugins enabled: 0

RECOMMENDATIONS:
	none

Additional information

I tried this using Windows 11 as well with the same result. Not a heavy emoji user, but it’s unexpected emoji don’t get passed to the PDF export.

3 Likes

I’ve got i bit better result. But not all emoji display correctly

1 Like

I have the same problem with other emoji too

This is a font problem

But how can we fix it? I tried most standard fonts to set: Arial, Comic Sans etc. The problem hasn’t gone

I’ve found out that it’s a problem with the font weight. The workaround I’m using now is to wrap the emoji(s) in a span that resets the font weight like this:

# <span style="font-weight: normal">πŸ“œ</span> Readme

This way the emoji will still be shown after exporting to pdf.

4 Likes

Thanks for the hack, 3xpl01t. Works for me too!