Embedded videos only render audio

Steps to reproduce

  • open an obsidian vault
  • create a note
  • drag and drop a local video file (.mp4 or .mov) to the note

Expected result

expected the player to render both audio and video.

Actual result

the player only renders audio:


Obsidian version: v1.1.9
Installer version: v1.1.9
Operating system: Darwin Kernel Version 21.6.0: Mon Aug 22 20:19:52 PDT 2022; root:xnu-8020.140.49~2/RELEASE_ARM64_T6000 21.6.0
Login status: not logged in
Insider build toggle: off
Live preview: on
Legacy editor: off
Base theme: dark
Community theme: none
Snippets enabled: 0
Restricted mode: on


Additional information


I can’t reproduce. Can you try this on the sandbox vault? Also, make sure the option Detect all file extensions is on within the Files & Links options in Obsidian

Sorry it wasn’t clear in my post, I have tested this in the sandbox environment with the same result.

I tried enabling Detect all file extensions within the Files & Links with no success.

I’m surprised that the issue wasn’t reproduce as I’ve been able to uninstall and reinstall obsidian and still see the issue. Could it be caused by some lingering metadata between installs?

@PR-C Did you test MacOS too? What kind of file did you test?

@jkarimi Can you open this media in a web browser? It might be a codec issue.

I just tested an mp4, and it worked fine. I also tested an HDR .mov file I took with my iPhone, and it only showed audio like in your report. But if I try and open the .mov in Firefox, it also only shows audio. So perhaps this is not exactly an Obsidian issue.

I tried to repro in MacOS Ventura 13.1 with an .mp4. Just tried a .mov and it also worked fine Maybe you can try with different file extensions? I think @rigmarole might be on the right track on this being an encoder issue. If you send a sample as @ariehen suggested, we can test it and see if we can repro

@ariehen @rigmarole & @PR-C I’m on MacOS 12.6 & a sample video file can be found here.

I just dragged and dropped this video into Obsidian’s Sandbox vault and it embedded without issue. If you try on a different computer you can rule out any cache. Another alternative will be to open a vault from a different folder and see if that works.

@PR-C that’s surprising. I tried opening a new vault that is located in a different folder didn’t work either :confused: .

Did you try on another computer? If it works, I recommend you use an app such as AppCleaner to remove Obsidian and all its associated files so that you can build it from scratch and see if it works.

@PR-C I tried this on another Mac running MacOS 12.5 that has never had obsidian installed and I was able to reproduce the issue. The common thread between the two Macs I’ve tested on are that they both have M series chips. Have you, @ariehen and/or @rigmarole tested this on a Mac with an M series chip?

I can reproduce it, including in another browser.

For the sample file that you can successfully use in Obsidian, does it also work for you if you open it in another browser like Firefox or Chrome? I’m guessing it will work for you.

(My hypothesis is that if the problem happens in Obsidian it will happen in another browser too. I bet this is a combination of computer/codec based.)

It works in safari. When I try to open it in chrome it tries to download the file instead of opening a player in the browser.

correction: the .mov version only works in safari. the .mp4 version works in safari and chrome but not in obsidian.

I tested in both Safari and Ungoogled Chromium and it worked on both. The Chromium version was an .mp4 convert as Chromium does not open .mov local files. Answering to @jkarimi I have an Intel Mac.

1 Like

This isn’t directly helpful, but there was a prior bug where some webm files had the same problem. It was fixed in an update but the thread doesn’t explain what the problem was. Failed to embed webm file as video

1 Like

@rigmarole any thoughts on @CawlinTeffid post?

Someone on Discord had an issue with a .mov not playing in the Canvas and/or a .mp4 only playing audio.

From Licat:

If it becomes an audio then it means the video codec isn’t supported on your computer or chromium (edited)

The most common case I’ve seen is if you took a video with an iPhone (or something in the Apple ecosystem) where the video codec is set to their proprietary one like HEVC, and then you try to view the video on a non-Apple device. Have it encode to a common codec such as H.264 or H.265 which is available on pretty much all modern devices.

1 Like

Hey! Hey!
I have the same problem, but it’s even weirder for me. I have 15 recordings from a conference, all from the same device, in the same format (mp4). They contain both video and audio. The first 5 after embedding render as I expect, as embedded video with audio. But the remaining ones do what was described above - embed only the audio recording.

These are recordings quite essential to my work, so I would really need to solve this problem, otherwise I would probably have to look for an alternative solution than Obsidian. :frowning:

Same(Avoiding close)

I have the same problem. I made recordings/movies on my iPhone, sent them through Airdrop to my Mac (Ventura version 13.4.1) and then dropped the movie in Obsidian from my Finder.

I see only audio and no movie. This happens for all the notes I’m working with today.

In the past, I could import movies without problems in this way. What is even more weird: movies I imported earlier are still visible as movies in Obsidian. But the movies I imported yesterday are only visible as sound file without images.

What is happening here? How can I solve this?