Embedded note section causes URL to attempt to embed

Steps to reproduce

  1. Create a note containing a header containing a Markdown URL link.
  2. Add some text below the header.
  1. Create a new note and embed the section, including the header from the original note.
  2. Add a Markdown URL link below the embedded section.

Obsidian attempts to embed the Markdown URL link in the note below the embed and doesn’t display the text of the note correctly.

This seems similar but a little different from this bug report:

Did you follow the troubleshooting guide? [Y/N]

Yes. This issue is reproducible in the sandbox vault as shown in the attached GIF showing the problem in action.

Expected result

The note’s text and Markdown link to be displayed as it normally would if the embedded note’s section isn’t displayed.

Actual result

The text of the Markdown link’s title is displayed with what appears to be a broken embed of the linked web page.

See the Sandbox vault GIF of this in action.


Obsidian version: v1.5.11
Installer version: v1.4.13
Operating system: Darwin Kernel Version 22.5.0: Mon Apr 24 20:52:24 PDT 2023; root:xnu-8796.121.2~5/RELEASE_ARM64_T6000 22.5.0
Login status: not logged in
Insider build toggle: off
Live preview: on
Base theme: light
Community theme: Minimal v7.5.3
Snippets enabled: 0
Restricted mode: off
Plugins installed: 17
Plugins enabled: 16
1: Auto Link Title v1.5.3
2: Calendar v1.5.10
3: Custom window title v0.3.5
4: Advanced Tables v0.21.0
5: Dataview v0.5.66
6: Templater v2.2.3
7: Note Refactor v1.8.2
8: Focus Mode v1.11.4
9: Better Word Count v0.10.1
10: Emoji Toolbar v0.4.1
11: Minimal Theme Settings v7.5.0
12: Hider v1.3.1
13: QuickAdd v1.8.1
14: Periodic Notes v0.0.17
15: Style Settings v1.0.8
16: Update modified date v1.3.2

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.
Community plugins: for bugs, please first try updating all your plugins to latest. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community plugins.

Additional information

Obsidian Embed Bug