Embedded Images won't display in Preview or as Page

I was able to use drag/drop to embed images in a note and have it display in Preview mode, but for some reason this has stopped working. I’ve restarted Obsidian multiple times, but it still won’t work.

I’ve tried the same in another vault, and the ![[image.png]] works there.

The only difference between the two is the template (California) and a calendar plugin, but that didn’t pose any problems in the past.

Can you share the raw text you’re using?

I hope this is what you mean, sorry I am new to this :smiley:

Hard to guess what’s going on, sorry… What happens if you drag the screenshot into the note?

unfortunately the exact same as in the first picture, just the thumbnail.

Ah, could it be the . in your folder with the screenshots?

Try removing that ..

1 Like

oh my goodness thank you so much!!

Hard to say without some examples—feel free to post screenshots and sample text!

Hi !

I think I’m having a similar problem, image files don’t show in editing (with ozan’s plugin) or view mode.

View mode (png don’t show):

Edit mode :
image

It seems to be image files specific as pdf preview from the same directory works fine.
It’s also specific to this vault, “Obsidian help” display images fine.

My operating system is Pop_Os! on Gnome.

Any pointers on ways to trouble shot / resolve this issue ?
Regards

If you change those to a link, does the image open?

A file open but no image is displayed :

This is not a file path resolution issue as same behavior occurs if I try to open the image directly. Also “open in default app” is also working using the link.

It sounds like an issue with those images. Maybe try a jpg?

Could it be the extra e in Attachements?

1 Like

It seems to be the case for all image file type not only png

tested :
png
jpg
gif
svg

Also pretty sure it’s not the typo in the folder name as file path is correctly resolved

I have just synced my vault on a Windows 10 computer and image preview work, so maybe it’s something specific to the OS ?

Weird. Anything is possible… mind submitting a bug report on this? Feel free to copy paste and please include the OS distinction!

Before filing that bug report I tried to reproduce on a fresh Ubuntu 20.04 with no success.

If I run Obsidian through AppImage it does work so the problem seems to be flatpak specific : (left is flatpak installed obsidian right is AppImage installation, note that both have the same version number)

I’m taking this to the flatpak tracker as the issue doesn’t seem to be obsidian.

Thanks for your help

1 Like