Editor Syntax Highlight plugin not working for python

Hmm I think I must be missing something obvious, but for some reason the Editor Syntax Highlight plugin doesn’t seem to highlight for me.

I’m trying to add syntax highlighting for python and I’m prefixing my codeblock with ```python3.

I don’t have any other third party plugins and I’m using the default light theme. Any idea what could be going wrong?

EDIT: I tried xml and js highlighting and those seem to work!

Try using ```python instead of ```python3. That works for me.

Oh nice! That worked. I guess I didn’t try that one. For anyone else reading, py also doesn’t work.

Syntax highlighting for Python is not working for me in Preview mode, but it works just fine in Edit mode (I’m using the Editor Syntax Highlight plugin).

For comparison, syntax highlight for JavaScript works fine in both modes.

Any idea why highlight is not working for Python in preview mode?

Here’s a sample snippet:

class Company:
    """Represents a company with employees."""

    def __init__(self) -> None:
        self.employees: List[Employee] = []

    def add_employee(self, employee: Employee) -> None:
        """Add an employee to the list of employees."""