Editor should respect Obsidian block based html convention

Steps to reproduce

1.) Create a note
2.) Create a live HTML preview. EX: <h1>Hello World!</h1>
3.) Place a tag below the preview.

Expected result

I expect to see a new tag appear within the graph view.

Actual result

Any tags that are put after the HTML preview do not appear in the graph.


  • Operating system: Ubuntu
  • Debug info:
    Obsidian version: v1.0.3
    Installer version: v1.0.3
    Operating system: #62-Ubuntu SMP Tue Nov 22 19:54:14 UTC 2022 5.15.0-56-generic
    Login status: not logged in
    Insider build toggle: off
    Live preview: on
    Legacy editor: off
    Base theme: dark
    Community theme: Atom
    Snippets enabled: 0
    Restricted mode: on

Custom theme and snippets: for cosmetic issues, please first try updating your theme and disabling your snippets. If still not fixed, please try to make the issue happen in the Sandbox Vault or disable community theme and snippets.

Additional information

Screenshot from 2022-12-10 23-35-07

#test1 and #test2 should be displayed in the graph.

This is actually correct. It’s LP that is mistakenly accepting test2 as tag. Reader is correct.
HTML blocks must be in their own markdown block (separated by blanklines)

I don’t understand. Is this an intentional feature? Or is there a way to fix this? I’m new to Obsidian so sorry if there is an obvious solution.

This is the correct way:


<h1>Hello World!</h1>


HTML should be in their own block.

Alright, I figured it out. I wasn’t sure what you meant by the blank lines at first but now I got it working. Thanks.