Editor behaves strange with nested unordered lists

Steps to reproduce

In settings turn off “indent using tabs” and set the “tab indent size” to 2

Then when creating a bulleted list while in source mode, create a 2x indented item. The editor inserts a large gap and pushed the 2 level indented line over about 4 extra spaces, but they aren’t real spaces. If you copy the text and paste it somewhere, or just inspect the codepoints, it is correctly 4 non-printing spaces. It just isn’t rendered properly. It renders correctly when viewing it in other modes outside of source mode though. For example:

  • top level
    • 1 level indented
      • 2 levels indented

This was copied from the sandbox vault, and looks fine, but renders with the text “- 2 levels indented” shifted way to far right.

Did you follow the troubleshooting guide? Y

Problem exists in the sandbox vault as well.

Expected result

I expect the editor correctly space the indention levels.

Actual result

Screenshot 2024-04-15 at 4.38.45 PM


Obsidian version: v1.5.12
Installer version: v1.4.13
Operating system: Darwin Kernel Version 22.6.0: Fri Sep 15 13:39:52 PDT 2023; root:xnu-8796.141.3.700.8~1/RELEASE_X86_64 22.6.0
Login status: not logged in
Insider build toggle: off
Live preview: on
Base theme: adapt to system
Community theme: none
Snippets enabled: 0
Restricted mode: on


Additional information